summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-24 08:02:08 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-24 08:02:08 +0000
commit34fddef43833b519d7117a9ba95e647c001f9bc5 (patch)
treea0da76103863341116980b14587cc33a56aa7c90 /sys-apps
parentup-da-to (diff)
downloadhistorical-34fddef43833b519d7117a9ba95e647c001f9bc5.tar.gz
historical-34fddef43833b519d7117a9ba95e647c001f9bc5.tar.bz2
historical-34fddef43833b519d7117a9ba95e647c001f9bc5.zip
new up-to-date XFS utils
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/acl/acl-20020124.ebuild25
-rw-r--r--sys-apps/acl/files/digest-acl-200201241
-rw-r--r--sys-apps/attr/attr-20020124.ebuild28
-rw-r--r--sys-apps/attr/files/digest-attr-200201241
-rw-r--r--sys-apps/dmapi/dmapi-20020124.ebuild29
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-200201241
-rw-r--r--sys-apps/xfsdump/files/digest-xfsdump-200201241
-rw-r--r--sys-apps/xfsdump/xfsdump-20020124.ebuild25
-rw-r--r--sys-apps/xfsprogs/files/digest-xfsprogs-200201241
-rw-r--r--sys-apps/xfsprogs/xfsprogs-20020124.ebuild25
10 files changed, 137 insertions, 0 deletions
diff --git a/sys-apps/acl/acl-20020124.ebuild b/sys-apps/acl/acl-20020124.ebuild
new file mode 100644
index 000000000000..b22ad4283590
--- /dev/null
+++ b/sys-apps/acl/acl-20020124.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-20020124.ebuild,v 1.1 2002/01/24 08:02:04 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="XFS dump/restore utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/sys-apps/acl/files/digest-acl-20020124 b/sys-apps/acl/files/digest-acl-20020124
new file mode 100644
index 000000000000..432516f563a9
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-20020124
@@ -0,0 +1 @@
+MD5 3b538a21f9d98f0cf7ab1ddde9086623 xfs-cmd-20020124.tar.bz2 1564672
diff --git a/sys-apps/attr/attr-20020124.ebuild b/sys-apps/attr/attr-20020124.ebuild
new file mode 100644
index 000000000000..07a5f355de5a
--- /dev/null
+++ b/sys-apps/attr/attr-20020124.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-20020124.ebuild,v 1.1 2002/01/24 08:02:05 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="xfs extended attributes tools"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+ dosym /usr/lib/libattr.a /lib/libattr.a
+ dosym /usr/lib/libattr.la /lib/libattr.la
+ dosym /lib/libattr.so /usr/lib/libattr.so
+}
diff --git a/sys-apps/attr/files/digest-attr-20020124 b/sys-apps/attr/files/digest-attr-20020124
new file mode 100644
index 000000000000..432516f563a9
--- /dev/null
+++ b/sys-apps/attr/files/digest-attr-20020124
@@ -0,0 +1 @@
+MD5 3b538a21f9d98f0cf7ab1ddde9086623 xfs-cmd-20020124.tar.bz2 1564672
diff --git a/sys-apps/dmapi/dmapi-20020124.ebuild b/sys-apps/dmapi/dmapi-20020124.ebuild
new file mode 100644
index 000000000000..3dddae16be8b
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-20020124.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-20020124.ebuild,v 1.1 2002/01/24 08:02:07 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="XFS data management API library"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ #let Steve Lord know that "install-dev" isn't mentioned in doc/INSTALL
+ make DESTDIR=${D} install install-dev || die
+ dosym /usr/lib/libdm.a /lib/libdm.a
+ dosym /usr/lib/libdm.la /lib/libdm.la
+ dosym /lib/libdm.so /usr/lib/libdm.so
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-20020124 b/sys-apps/dmapi/files/digest-dmapi-20020124
new file mode 100644
index 000000000000..432516f563a9
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-20020124
@@ -0,0 +1 @@
+MD5 3b538a21f9d98f0cf7ab1ddde9086623 xfs-cmd-20020124.tar.bz2 1564672
diff --git a/sys-apps/xfsdump/files/digest-xfsdump-20020124 b/sys-apps/xfsdump/files/digest-xfsdump-20020124
new file mode 100644
index 000000000000..432516f563a9
--- /dev/null
+++ b/sys-apps/xfsdump/files/digest-xfsdump-20020124
@@ -0,0 +1 @@
+MD5 3b538a21f9d98f0cf7ab1ddde9086623 xfs-cmd-20020124.tar.bz2 1564672
diff --git a/sys-apps/xfsdump/xfsdump-20020124.ebuild b/sys-apps/xfsdump/xfsdump-20020124.ebuild
new file mode 100644
index 000000000000..3fcb99322a78
--- /dev/null
+++ b/sys-apps/xfsdump/xfsdump-20020124.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsdump/xfsdump-20020124.ebuild,v 1.1 2002/01/24 08:02:07 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="xfs dump/restore utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs >=sys-apps/xfsprogs-${PV} >=sys-apps/dmapi-${PV} >=sys-apps/attr-${PV}"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/sys-apps/xfsprogs/files/digest-xfsprogs-20020124 b/sys-apps/xfsprogs/files/digest-xfsprogs-20020124
new file mode 100644
index 000000000000..432516f563a9
--- /dev/null
+++ b/sys-apps/xfsprogs/files/digest-xfsprogs-20020124
@@ -0,0 +1 @@
+MD5 3b538a21f9d98f0cf7ab1ddde9086623 xfs-cmd-20020124.tar.bz2 1564672
diff --git a/sys-apps/xfsprogs/xfsprogs-20020124.ebuild b/sys-apps/xfsprogs/xfsprogs-20020124.ebuild
new file mode 100644
index 000000000000..d92f7729c7e7
--- /dev/null
+++ b/sys-apps/xfsprogs/xfsprogs-20020124.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/xfsprogs-20020124.ebuild,v 1.1 2002/01/24 08:02:08 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="xfs filesystem utilities"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} DK_INC_DIR=${D}/usr/include/disk install install-dev || die
+}