summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-07 20:04:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-07 20:04:08 +0000
commita99bb888f4bf5416cbaa4e51cf1e11c882c7dab2 (patch)
treeb032ab4e525346787ad3611d6c63cb77f79fbad6 /sys-apps/x86info/x86info-1.24-r1.ebuild
parentSparc stable, bug #267960. (diff)
downloadhistorical-a99bb888f4bf5416cbaa4e51cf1e11c882c7dab2.tar.gz
historical-a99bb888f4bf5416cbaa4e51cf1e11c882c7dab2.tar.bz2
historical-a99bb888f4bf5416cbaa4e51cf1e11c882c7dab2.zip
Remove ChangeLog from dodoc wrt #265591, thanks to Victor Ostorga. Make use of toolchain-funcs for CC.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/x86info/x86info-1.24-r1.ebuild')
-rw-r--r--sys-apps/x86info/x86info-1.24-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-apps/x86info/x86info-1.24-r1.ebuild b/sys-apps/x86info/x86info-1.24-r1.ebuild
index fadce9f8a3b0..ac30e02d5e53 100644
--- a/sys-apps/x86info/x86info-1.24-r1.ebuild
+++ b/sys-apps/x86info/x86info-1.24-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.24-r1.ebuild,v 1.1 2009/04/12 20:39:04 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.24-r1.ebuild,v 1.2 2009/05/07 20:04:08 ssuominen Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
@@ -23,7 +23,8 @@ src_unpack() {
}
src_compile() {
- emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+ emake x86info CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" || die "emake failed"
}
pkg_preinst() {
@@ -40,7 +41,7 @@ src_install() {
insinto /etc/modprobe.d
newins "${FILESDIR}"/x86info-modules.conf-rc x86info
- dodoc TODO README ChangeLog
+ dodoc TODO README
doman x86info.1
insinto /usr/share/doc/${PF}
doins -r results