summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-11-15 01:44:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-11-15 01:44:54 +0000
commitca3158869f3a85afc2897edffddd17f70344718b (patch)
treed5c50b2045632c6d8adc276d011d4e341190adcd /sys-apps/x86info/x86info-1.12b.ebuild
parentversion bump per bug #33426, and metadata.xml (diff)
downloadhistorical-ca3158869f3a85afc2897edffddd17f70344718b.tar.gz
historical-ca3158869f3a85afc2897edffddd17f70344718b.tar.bz2
historical-ca3158869f3a85afc2897edffddd17f70344718b.zip
version bump per bug #33426, and metadata.xml
Diffstat (limited to 'sys-apps/x86info/x86info-1.12b.ebuild')
-rw-r--r--sys-apps/x86info/x86info-1.12b.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/x86info/x86info-1.12b.ebuild b/sys-apps/x86info/x86info-1.12b.ebuild
new file mode 100644
index 000000000000..af8c2f0d3039
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.12b.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.12b.ebuild,v 1.1 2003/11/15 01:44:43 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/${PN}/"
+SRC_URI="${HOMEPAGE}/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 -ppc -sparc -mips -alpha -arm -hppa"
+DEPEND="virtual/kernel"
+RDEPEND=""
+IUSE=""
+S=${WORKDIR}/${P}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # binaries first
+ into /usr
+ dobin x86info
+ # modules stuff next
+ insinto /etc/modules.d
+ newins ${FILESDIR}/x86info-modules.conf-rc x86info
+ # now we all all the docs
+ dodoc TODO README COPYING ChangeLog
+ doman x86info.1
+ cp -a results ${D}/usr/share/doc/${PF}
+ # prepalldocs rocks! I saw it in net-fs/samba/samba-2.2.8
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+ # copied from media-libs/svgalib/svgalib-1.9.17
+ if [ "${ROOT}" = "/" ]; then
+ /sbin/modules-update &> /dev/null
+
+ # create device nodes for x86info
+ # based off the scripts/makenode
+ # there isn't any proper devfs support in cpuid/msr
+ einfo "Creating device nodes for x86info"
+ mkdir -p ${ROOT}/dev/cpu
+ local numprocs
+ #subtract one because we are using a 0-based count
+ numprocs=$((`grep -c '^processor' /proc/cpuinfo`-1))
+ for i in `seq 0 $numprocs`; do
+ mkdir ${ROOT}/dev/cpu/$i
+ mknod ${ROOT}/dev/cpu/$i/cpuid c 203 $i 2>/dev/null
+ mknod ${ROOT}/dev/cpu/$i/msr c 202 $i 2>/dev/null
+ done
+ fi
+}