summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-10-18 17:27:33 +0000
committerMichael Januszewski <spock@gentoo.org>2008-10-18 17:27:33 +0000
commit5836937bf89ee9fff6ff699551aa79d5a43b6897 (patch)
treed6343f72fc67eb61b4097c99f7cc4955c502a4a6 /sys-apps/v86d
parentFix download of templates packages, see bug #242494 (diff)
downloadhistorical-5836937bf89ee9fff6ff699551aa79d5a43b6897.tar.gz
historical-5836937bf89ee9fff6ff699551aa79d5a43b6897.tar.bz2
historical-5836937bf89ee9fff6ff699551aa79d5a43b6897.zip
Remove old ebuilds.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27 x86_64
Diffstat (limited to 'sys-apps/v86d')
-rw-r--r--sys-apps/v86d/ChangeLog6
-rw-r--r--sys-apps/v86d/v86d-0.1.5.2.ebuild52
-rw-r--r--sys-apps/v86d/v86d-0.1.6.ebuild52
-rw-r--r--sys-apps/v86d/v86d-0.1.7.ebuild52
-rw-r--r--sys-apps/v86d/v86d-0.1.8.ebuild53
5 files changed, 5 insertions, 210 deletions
diff --git a/sys-apps/v86d/ChangeLog b/sys-apps/v86d/ChangeLog
index 03c8c951089f..9035919051d2 100644
--- a/sys-apps/v86d/ChangeLog
+++ b/sys-apps/v86d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/v86d
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.27 2008/10/04 09:38:55 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.28 2008/10/18 17:27:33 spock Exp $
+
+ 18 Oct 2008; Michał Januszewski <spock@gentoo.org> -v86d-0.1.5.2.ebuild,
+ -v86d-0.1.6.ebuild, -v86d-0.1.7.ebuild, -v86d-0.1.8.ebuild:
+ Remove old ebuilds.
04 Oct 2008; Michał Januszewski <spock@gentoo.org> v86d-0.1.9.ebuild:
Remove unused inherits, use emake instead of make.
diff --git a/sys-apps/v86d/v86d-0.1.5.2.ebuild b/sys-apps/v86d/v86d-0.1.5.2.ebuild
deleted file mode 100644
index 25068411c9c7..000000000000
--- a/sys-apps/v86d/v86d-0.1.5.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.5.2.ebuild,v 1.1 2008/07/16 20:53:42 spock Exp $
-
-inherit linux-info multilib
-
-DESCRIPTION="A daemon to run x86 code in an emulated environment."
-HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
-SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug x86emu"
-
-DEPEND="dev-libs/klibc"
-RDEPEND=""
-
-S="${WORKDIR}/${P//_*/}"
-
-pkg_setup() {
- if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
- eerror "You need to compile klibc against a kernel tree patched with uvesafb"
- eerror "prior to merging this package."
- die "Kernel not patched with uvesafb."
- fi
- linux-info_pkg_setup
-}
-
-src_compile() {
- local myconf=""
- if use x86emu ; then
- myconf="--with-x86emu"
- fi
-
- ./configure --with-klibc $(use_with debug) ${myconf}
- make KDIR=${KV_DIR} || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- dodoc README ChangeLog
-
- insinto /usr/share/${PN}
- doins misc/initramfs
-}
-
-pkg_postinst() {
- elog "If you wish to place v86d into an initramfs image, you might want to use"
- elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
-}
diff --git a/sys-apps/v86d/v86d-0.1.6.ebuild b/sys-apps/v86d/v86d-0.1.6.ebuild
deleted file mode 100644
index 417487d37a45..000000000000
--- a/sys-apps/v86d/v86d-0.1.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.6.ebuild,v 1.1 2008/07/26 15:23:39 spock Exp $
-
-inherit linux-info multilib
-
-DESCRIPTION="A daemon to run x86 code in an emulated environment."
-HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
-SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug x86emu"
-
-DEPEND="dev-libs/klibc"
-RDEPEND=""
-
-S="${WORKDIR}/${P//_*/}"
-
-pkg_setup() {
- if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
- eerror "You need to compile klibc against a kernel tree patched with uvesafb"
- eerror "prior to merging this package."
- die "Kernel not patched with uvesafb."
- fi
- linux-info_pkg_setup
-}
-
-src_compile() {
- local myconf=""
- if use x86emu ; then
- myconf="--with-x86emu"
- fi
-
- ./configure --with-klibc $(use_with debug) ${myconf}
- make KDIR=${KV_DIR} || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- dodoc README ChangeLog
-
- insinto /usr/share/${PN}
- doins misc/initramfs
-}
-
-pkg_postinst() {
- elog "If you wish to place v86d into an initramfs image, you might want to use"
- elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
-}
diff --git a/sys-apps/v86d/v86d-0.1.7.ebuild b/sys-apps/v86d/v86d-0.1.7.ebuild
deleted file mode 100644
index 1d8332759f19..000000000000
--- a/sys-apps/v86d/v86d-0.1.7.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.7.ebuild,v 1.1 2008/09/14 15:08:42 spock Exp $
-
-inherit linux-info multilib
-
-DESCRIPTION="A daemon to run x86 code in an emulated environment."
-HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
-SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug x86emu"
-
-DEPEND="dev-libs/klibc"
-RDEPEND=""
-
-S="${WORKDIR}/${P//_*/}"
-
-pkg_setup() {
- if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
- eerror "You need to compile klibc against a kernel tree patched with uvesafb"
- eerror "prior to merging this package."
- die "Kernel not patched with uvesafb."
- fi
- linux-info_pkg_setup
-}
-
-src_compile() {
- local myconf=""
- if use x86emu ; then
- myconf="--with-x86emu"
- fi
-
- ./configure --with-klibc $(use_with debug) ${myconf}
- make KDIR="${KV_DIR}" || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- dodoc README ChangeLog
-
- insinto /usr/share/${PN}
- doins misc/initramfs
-}
-
-pkg_postinst() {
- elog "If you wish to place v86d into an initramfs image, you might want to use"
- elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
-}
diff --git a/sys-apps/v86d/v86d-0.1.8.ebuild b/sys-apps/v86d/v86d-0.1.8.ebuild
deleted file mode 100644
index 38e4f6d939d0..000000000000
--- a/sys-apps/v86d/v86d-0.1.8.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.8.ebuild,v 1.2 2008/09/27 20:02:32 spock Exp $
-
-inherit eutils linux-info multilib
-
-DESCRIPTION="A daemon to run x86 code in an emulated environment."
-HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
-SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug x86emu"
-
-DEPEND="dev-libs/klibc"
-RDEPEND=""
-
-S="${WORKDIR}/${P//_*/}"
-
-pkg_setup() {
- if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
- eerror "You need to compile klibc against a kernel tree patched with uvesafb"
- eerror "prior to merging this package."
- die "Kernel not patched with uvesafb."
- fi
- linux-info_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-concurrent-make.patch"
-}
-
-src_compile() {
- ./configure --with-klibc $(use_with debug) $(use_with x86emu)
- make KDIR="${KV_DIR}" || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- dodoc README ChangeLog
-
- insinto /usr/share/${PN}
- doins misc/initramfs
-}
-
-pkg_postinst() {
- elog "If you wish to place v86d into an initramfs image, you might want to use"
- elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
-}