summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-09 23:26:55 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-09 23:26:55 +0000
commitfe2f54c2940574be412b744095b0e874f52568ae (patch)
treed1f4359c27a122f79e2ee110d8840ac640f72360 /sys-apps/slocate
parentupdated URL, removed old version, and added SLOT in the meantime (diff)
downloadhistorical-fe2f54c2940574be412b744095b0e874f52568ae.tar.gz
historical-fe2f54c2940574be412b744095b0e874f52568ae.tar.bz2
historical-fe2f54c2940574be412b744095b0e874f52568ae.zip
slocate 2.6: a secure drop-in replacement for locate and updatedb
Diffstat (limited to 'sys-apps/slocate')
-rw-r--r--sys-apps/slocate/files/digest-slocate-2.61
-rw-r--r--sys-apps/slocate/slocate-2.6.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/slocate/files/digest-slocate-2.6 b/sys-apps/slocate/files/digest-slocate-2.6
new file mode 100644
index 000000000000..dcea05d8415f
--- /dev/null
+++ b/sys-apps/slocate/files/digest-slocate-2.6
@@ -0,0 +1 @@
+MD5 52fb87a7aaa68650ecf1461a9a6df781 slocate-2.6.tar.gz 69462
diff --git a/sys-apps/slocate/slocate-2.6.ebuild b/sys-apps/slocate/slocate-2.6.ebuild
new file mode 100644
index 000000000000..2a7bef81be3c
--- /dev/null
+++ b/sys-apps/slocate/slocate-2.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.6.ebuild,v 1.1 2002/02/09 23:26:55 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Secure locate provides a secure way to index and quickly search for files on your system (drop-in replacement for 'locate')"
+SRC_URI="ftp://ftp.geekreview.org/slocate/src/slocate-${PV}.tar.gz"
+HOMEPAGE="http://www.geekreview.org/slocate/"
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+
+src_install() {
+
+ # make install for this package is blocked by sandbox
+ dobin slocate
+ dosym /usr/bin/slocate /usr/bin/locate
+ dosym /usr/bin/slocate /usr/bin/updatedb
+
+ dodir /var/lib/slocate ; touch ${D}/var/lib/slocate/.keep
+
+ insinto /etc/cron.daily
+ chmod +x slocate.cron
+ doins slocate.cron
+
+ # man pages are already compressed for us
+ insinto /usr/share/man/man1
+ mv doc/slocate.1.linux.gz doc/slocate.1.gz
+ doins doc/slocate.1.gz doc/updatedb.1.gz
+ dosym /usr/share/man/man1/slocate.1.gz /usr/share/man/man1/locate.1.gz
+
+ dodoc LICENSE COPYING AUTHORS NEWS README ChangeLog
+}
+
+pkg_postinst() {
+ # /var/lib/slocate is owned by group slocate and so is the executable
+ groupadd slocate
+
+ chown root.slocate /usr/bin/slocate
+ chmod 2755 /usr/bin/slocate
+
+ chown root.slocate /var/lib/slocate
+ chmod 0750 /var/lib/slocate
+}