summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2002-04-27 10:41:11 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2002-04-27 10:41:11 +0000
commit763569e380eaebb6c1542f7f06745077fc65a64b (patch)
treec3e2d79cc1778061fd10bbd736260e57ce3d580e /sys-apps/quik
parentcleanup (diff)
downloadhistorical-763569e380eaebb6c1542f7f06745077fc65a64b.tar.gz
historical-763569e380eaebb6c1542f7f06745077fc65a64b.tar.bz2
historical-763569e380eaebb6c1542f7f06745077fc65a64b.zip
PPC sys-apps merge
Diffstat (limited to 'sys-apps/quik')
-rw-r--r--sys-apps/quik/Changelog9
-rw-r--r--sys-apps/quik/files/digest-quik-2.0.1.0-r12
-rw-r--r--sys-apps/quik/quik-2.0.1.0-r1.ebuild80
3 files changed, 91 insertions, 0 deletions
diff --git a/sys-apps/quik/Changelog b/sys-apps/quik/Changelog
new file mode 100644
index 000000000000..68eaca504378
--- /dev/null
+++ b/sys-apps/quik/Changelog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/quik
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Id: Changelog,v 1.1 2002/04/27 10:38:37 pvdabeel Exp $
+
+*quik-2.0.1.0-r1 (Wed Apr 24 10:34:12 2002 CEST)
+
+Wed Apr 24 10:34:56 2002 CEST; pvdabeel <pvdabeel@gentoo.org> all:
+
+ This is an initial .ebuild for quik-2.0.1.0-r1 for ppc machines.
diff --git a/sys-apps/quik/files/digest-quik-2.0.1.0-r1 b/sys-apps/quik/files/digest-quik-2.0.1.0-r1
new file mode 100644
index 000000000000..1aa7f3e72997
--- /dev/null
+++ b/sys-apps/quik/files/digest-quik-2.0.1.0-r1
@@ -0,0 +1,2 @@
+MD5 d546fd92dfa16255e062fa8505a5b8d4 quik_2.0e.orig.tar.gz 39440
+MD5 71828c98994bf3a3f7d08bc0672e33e5 quik_2.0e-1.diff.gz 7694
diff --git a/sys-apps/quik/quik-2.0.1.0-r1.ebuild b/sys-apps/quik/quik-2.0.1.0-r1.ebuild
new file mode 100644
index 000000000000..9cf541df429a
--- /dev/null
+++ b/sys-apps/quik/quik-2.0.1.0-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Pieter Van den Abeele <pvdabeel@gentoo.org>
+# Author: Adrian Rutledge <atma@ayerie.dnsalias.net>
+# $Id: quik-2.0.1.0-r1.ebuild,v 1.1 2002/04/27 10:38:37 pvdabeel Exp $
+
+S="${WORKDIR}/quik-2.0"
+A="quik_2.0e.orig.tar.gz"
+
+echo "workdir is:"
+echo ${WORKDIR}
+
+DEB_P="quik_2.0e-1.diff"
+DEB_URI="ftp://ftp.debian.org/debian/pool/main/q/quik"
+
+DESCRIPTION="OldWorld PowerMac Bootloader"
+
+SRC_URI="${DEB_URI}/${A} ${DEB_URI}/${DEB_P}.gz"
+
+DEPEND="virtual/glibc"
+RDEPEND=""
+
+pkg_setup() {
+ [ "${ROOT}" != "/" ] && return 0
+ . ${ROOT}/etc/init.d/functions.sh
+ local fstabstate="$(cat /etc/fstab |grep -v -e '#' |awk '{print $2}')"
+ local procstate="$(cat /proc/mounts |awk '{print $2}')"
+ if [ -n "$(echo ${fstabstate} |grep -e "/boot")" ] && \
+ [ -n "$(echo ${procstate} |grep -e "/boot")" ]
+ then
+ einfo "Your boot partition was detected as being mounted as /boot."
+ einfo "Files will be installed there for this bootloader to function correctly."
+ elif [ -n "$(echo ${fstabstate} |grep -e "/boot")" ] && \
+ [ -z "$(echo ${procstate} |grep -e "/boot")" ]
+ then
+ mount /boot &>/dev/null
+ if [ "$?" -eq 0 ]
+ then
+ einfo "Your boot partition was not mounted as /boot, but portage was able to mount"
+ einfo "it without additional intervention."
+ einfo "Files will be installed there for this bootloader to function correctly."
+ else
+ eerror "Your boot partition has to be mounted on /boot before the installation"
+ eerror "can continue. This bootloader needs to install important files there."
+ die "Please mount your /boot partition."
+ fi
+ else
+ einfo "You do not have a seperate /boot partition."
+ fi
+}
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A} || die
+ zcat ${DISTDIR}/${DEB_P}.gz | patch -p1 -d ${S}|| die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+
+ # 'll have a look at this later
+
+ install -d -m 755 ${D}/sbin || die
+ install -d -m 755 ${D}/etc || die
+ install -d -m 755 ${D}/boot || die
+ install -d -m 755 ${D}/usr/share/man/man5 || die
+ install -d -m 755 ${D}/usr/share/man/man8 || die
+ install -s -m 755 quik/quik ${D}/sbin || DIE
+ install -m 644 man/quik.conf.5 \
+ ${D}/usr/share/man/man5 || DIE
+ install -m 644 man/quik.8 man/bootstrap.8 \
+ ${D}/usr/share/man/man8 || DIE
+
+ install -m 444 first/first.b second/second.b \
+ second/second ${D}/boot || die
+ install -m 644 etc/quik.conf ${D}/etc || die
+}