summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-02-20 12:55:28 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-02-20 12:55:28 +0000
commit1ba55776c35eb8ffb70370b95527f805e30a6881 (patch)
tree1281e6c9820be65cbbe919c84c02f796f0890bd9 /sys-apps/parted/parted-1.6.6-r1.ebuild
parentMarked stable on hppa. (diff)
downloadhistorical-1ba55776c35eb8ffb70370b95527f805e30a6881.tar.gz
historical-1ba55776c35eb8ffb70370b95527f805e30a6881.tar.bz2
historical-1ba55776c35eb8ffb70370b95527f805e30a6881.zip
hfsplus patch updated
Diffstat (limited to 'sys-apps/parted/parted-1.6.6-r1.ebuild')
-rw-r--r--sys-apps/parted/parted-1.6.6-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/parted/parted-1.6.6-r1.ebuild b/sys-apps/parted/parted-1.6.6-r1.ebuild
new file mode 100644
index 000000000000..d8cb39efde4a
--- /dev/null
+++ b/sys-apps/parted/parted-1.6.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.6-r1.ebuild,v 1.1 2004/02/20 12:55:28 lu_zero Exp $
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="http://www.gnu.org/software/parted"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=" ~ppc ~ppc64 -*"
+IUSE="nls static readline debug noreiserfs"
+
+DEPEND=">=sys-fs/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ readline? ( >=sys-libs/readline-4.1-r4 )"
+RDEPEND="${DEPEND}
+ !noreiserfs? ( =sys-fs/progsreiserfs-0.3.0* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-assert.patch
+ epatch ${FILESDIR}/${P}-hfs-9.patch
+ epatch ${FILESDIR}/${P}-gcc-3.3.patch
+ epatch ${FILESDIR}/${P}-2-6headers.patch
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use readline || myconf="${myconf} --without-readline"
+ use debug || myconf="${myconf} --disable-debug"
+ use static && myconf="${myconf} --enable-all-static"
+ econf --target=${CHOST} ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog \
+ INSTALL NEWS README THANKS TODO
+ docinto doc; cd doc
+ dodoc API COPYING.DOC FAQ FAT USER USER.jp
+}