summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-10-19 20:23:50 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-10-19 20:23:50 +0000
commit37522c6e5c95888aaa8c9afe6293bf13733330b6 (patch)
tree2fd17e81b32f99f275f847de0e1de5a6d3c4f46a /sys-apps/netkit-base/netkit-base-0.17-r9.ebuild
parentAdded libertas-fw to license group BINARY-REDISTRIBUTABLE (diff)
downloadhistorical-37522c6e5c95888aaa8c9afe6293bf13733330b6.tar.gz
historical-37522c6e5c95888aaa8c9afe6293bf13733330b6.tar.bz2
historical-37522c6e5c95888aaa8c9afe6293bf13733330b6.zip
Instill LDFLAGS respect into build system. Port to EAPI=2. Closes bug #337448 by Diego Elio "Flameeyes" Pettenò <flameeyes@gentoo.org>.
Package-Manager: portage-2.1.9.20/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/netkit-base/netkit-base-0.17-r9.ebuild')
-rw-r--r--sys-apps/netkit-base/netkit-base-0.17-r9.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/netkit-base/netkit-base-0.17-r9.ebuild b/sys-apps/netkit-base/netkit-base-0.17-r9.ebuild
new file mode 100644
index 000000000000..e74ce161e66f
--- /dev/null
+++ b/sys-apps/netkit-base/netkit-base-0.17-r9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netkit-base/netkit-base-0.17-r9.ebuild,v 1.1 2010/10/19 20:23:50 chainsaw Exp $
+
+EAPI=2
+
+inherit base
+
+DESCRIPTION="Old-style inetd"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+PROVIDE="virtual/inetd"
+EPATCH_SUFFIX="patch"
+PATCHES=( "${FILESDIR}" )
+
+src_configure() {
+ ./configure || die
+ sed -e "s:^CFLAGS=.*:CFLAGS=${CFLAGS} -Wall -Wbad-function-cast -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline:" \
+ MCONFIG > MCONFIG.new || die "Unable to set CFLAGS for build"
+ sed -e "s:^LDFLAGS=.*:LDFLAGS=${LDFLAGS}:" \
+ MCONFIG.new > MCONFIG || die "Unable to set LDFLAGS for build"
+}
+
+src_install() {
+ sed -i \
+ -e 's:in\.telnetd$:in.telnetd -L /usr/sbin/telnetlogin:' \
+ etc.sample/inetd.conf
+
+ dosbin inetd/inetd
+ doman inetd/inetd.8
+ newinitd "${FILESDIR}"/inetd.rc6 inetd
+
+ dodoc BUGS ChangeLog README
+ docinto samples ; dodoc etc.sample/*
+}