summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-01-11 02:44:46 +0000
committerNed Ludd <solar@gentoo.org>2005-01-11 02:44:46 +0000
commit57b91231084ed96a3a2693c43d786a786cebb3cb (patch)
tree096b0c7ef950d99ccce2dad6f727c25c9dd5148e /sys-apps/memtest86
parentBug #64331, Bug #51138, Bug #70062 (diff)
downloadhistorical-57b91231084ed96a3a2693c43d786a786cebb3cb.tar.gz
historical-57b91231084ed96a3a2693c43d786a786cebb3cb.tar.bz2
historical-57b91231084ed96a3a2693c43d786a786cebb3cb.zip
- fixed problem with missing ssp symbols. bug #76495
Diffstat (limited to 'sys-apps/memtest86')
-rw-r--r--sys-apps/memtest86/ChangeLog6
-rw-r--r--sys-apps/memtest86/Manifest17
-rw-r--r--sys-apps/memtest86/files/memtest86-3.2-solar.patch27
-rw-r--r--sys-apps/memtest86/memtest86-3.2.ebuild4
4 files changed, 44 insertions, 10 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
index acfd077859fb..f0783300bfa2 100644
--- a/sys-apps/memtest86/ChangeLog
+++ b/sys-apps/memtest86/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/memtest86
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.24 2005/01/11 01:50:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.25 2005/01/11 02:44:36 solar Exp $
+
+ 10 Jan 2005; <solar@gentoo.org> +files/memtest86-3.2-solar.patch,
+ memtest86-3.2.ebuild:
+ - fixed problem with missing ssp symbols. bug #76495
10 Jan 2005; Mike Frysinger <vapier@gentoo.org> memtest86-3.2.ebuild:
Disable src_test (since one doesnt exist) #77368 and only add PIC patch if
diff --git a/sys-apps/memtest86/Manifest b/sys-apps/memtest86/Manifest
index a070add5b6dd..0222329b5779 100644
--- a/sys-apps/memtest86/Manifest
+++ b/sys-apps/memtest86/Manifest
@@ -1,15 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 0076775a66ee96e6304169122b9f8f1d ChangeLog 3829
+MD5 6013644feb6f557d1c302e57622eeea2 memtest86-3.2.ebuild 1944
+MD5 1fe8f6c465d839e2ac1d9d2064f48dd3 ChangeLog 3976
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 e2581cba8e65a0a7ff450d36acfb6e02 memtest86-3.2.ebuild 1947
-MD5 64a30db4579e12539572f71ca895e1ed files/digest-memtest86-3.2 65
MD5 9b8f71a15e2d7236b658f1f9e0fb79df files/memtest86-3.2-test-pic.patch 641
+MD5 93e1541e7b5f0da25dc394b281830ba1 files/memtest86-3.2-solar.patch 821
+MD5 64a30db4579e12539572f71ca895e1ed files/digest-memtest86-3.2 65
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.14 (GNU/Linux)
+Version: GnuPG v1.2.4 (GNU/Linux)
-iD8DBQFB4zEBroRuSHgZdywRAhA5AJ90kQFOf9EqLcZJEyE6q3IZ444dnQCeIzY0
-75D6YLGCJfl++u6kpY4+V5I=
-=EtUi
+iQCVAwUBQeM9D54WFLgrx1GWAQLbqQP8D3dEmnOqZ7nyCxjBP9S36l03HmZ0qi+K
+gB9Uzd1C54O4e3yQFhDmobcPA7u2EGpYjK2QEDUvyV32Gup6hxd1VKxvcwTFUIJd
+a4dTy6on6e0GqM7Sc76NDggqdE4PNBE3TPbthAAVXUVbXbYyy+e/6RyaJ8mXgiAA
+qPGwVreSpiY=
+=ToP5
-----END PGP SIGNATURE-----
diff --git a/sys-apps/memtest86/files/memtest86-3.2-solar.patch b/sys-apps/memtest86/files/memtest86-3.2-solar.patch
new file mode 100644
index 000000000000..fa7effbeaac4
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-3.2-solar.patch
@@ -0,0 +1,27 @@
+--- Makefile.orig 2004-11-12 07:16:25.000000000 -0500
++++ Makefile 2005-01-10 21:35:19.000000000 -0500
+@@ -12,7 +12,7 @@
+ #
+ # gcc compiler options, these settings should suffice
+ #
+-CCFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding
++CCFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector
+
+ AS=as -32
+
+@@ -21,10 +21,13 @@
+ all: memtest.bin memtest
+
+ reloc.o: reloc.c
+- $(CC) -c -m32 -fPIC -Wall -O -fno-strict-aliasing reloc.c
++ $(CC) -c -m32 -fPIC -Wall -O -fno-strict-aliasing reloc.c -fno-stack-protector
++
++random.o:
++ $(CC) -c $(CCFLAGS) -fPIC random.c
+
+ test.o: test.c test.h defs.h config.h
+- $(CC) -c $(CCFLAGS) test.c
++ $(CC) -c $(CCFLAGS) -fno-PIC test.c
+
+ main.o: main.c test.h defs.h
+ $(CC) -c $(CCFLAGS) -fPIC main.c
diff --git a/sys-apps/memtest86/memtest86-3.2.ebuild b/sys-apps/memtest86/memtest86-3.2.ebuild
index 3a384b0fb78b..7dcd3d25f62c 100644
--- a/sys-apps/memtest86/memtest86-3.2.ebuild
+++ b/sys-apps/memtest86/memtest86-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.2.ebuild,v 1.3 2005/01/11 01:50:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.2.ebuild,v 1.4 2005/01/11 02:44:36 solar Exp $
inherit mount-boot eutils flag-o-matic
@@ -21,7 +21,7 @@ src_unpack() {
cd "${S}"
test_flag -fno-stack-protector && \
- epatch "${FILESDIR}"/${P}-test-pic.patch #66630
+ epatch "${FILESDIR}"/${P}-solar.patch #66630
sed -i -e '/DISCARD/d' memtest_shared.lds