summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-30 23:14:35 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-30 23:14:35 +0000
commit65ff9109d975303a292ac9e7acd38261c91079cc (patch)
tree984b1519ba60a35ae6d27439329dcf5b4f984668 /sys-apps/iproute2
parentPrepared for rc3 (diff)
downloadhistorical-65ff9109d975303a292ac9e7acd38261c91079cc.tar.gz
historical-65ff9109d975303a292ac9e7acd38261c91079cc.tar.bz2
historical-65ff9109d975303a292ac9e7acd38261c91079cc.zip
Prepared for rc3
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/iproute2-2.2.4.ebuild24
1 files changed, 21 insertions, 3 deletions
diff --git a/sys-apps/iproute2/iproute2-2.2.4.ebuild b/sys-apps/iproute2/iproute2-2.2.4.ebuild
index 2cb0ccca833c..eec63bccd5f8 100644
--- a/sys-apps/iproute2/iproute2-2.2.4.ebuild
+++ b/sys-apps/iproute2/iproute2-2.2.4.ebuild
@@ -1,15 +1,23 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.2.4.ebuild,v 1.1 2000/11/05 02:52:16 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.2.4.ebuild,v 1.2 2000/11/30 23:14:33 achim Exp $
A=iproute2-2.2.4-now-ss001007.tar.gz
S=${WORKDIR}/iproute2
DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${A}"
+DEPEND=">=sys-libs/glibc-2.1.3"
+RDEPEND="$DEPEND
+ >=sys-apps/bash-2.04"
src_compile() {
- try make
+ try make ${MAKEOPTS}
+ if [ "`use tex`" ]
+ then
+ cd doc
+ try make
+ fi
}
src_unpack() {
@@ -26,10 +34,20 @@ src_install() {
cd ${S}/tc
dosbin tc
cd ${S}
- dodoc README* RELNOTES examples/*
+ dodoc README* RELNOTES
+ docinto examples
+ dodoc examples/*
+ docinto examples/diffserv
+ dodoc examples/diffserv/*
dodir /etc/iproute2
insinto /etc/iproute2
doins ${S}/etc/iproute2/*
+ if [ "`use tex`" ]
+ then
+ docinto ps
+ dodoc doc/*.ps
+ fi
+
}