summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-08-06 18:00:34 +0000
committerWout Mertens <wmertens@gentoo.org>2003-08-06 18:00:34 +0000
commit350c775030bd1523b16d2b15bd3ca195eb016204 (patch)
treeb4c68d1dabb3193e97caf7cce1a4eda825fd4370 /sys-apps/ifplugd/ifplugd-0.15.ebuild
parentMarked stable (diff)
downloadhistorical-350c775030bd1523b16d2b15bd3ca195eb016204.tar.gz
historical-350c775030bd1523b16d2b15bd3ca195eb016204.tar.bz2
historical-350c775030bd1523b16d2b15bd3ca195eb016204.zip
Version bump, probably much more stable than 0.13, *PLEASE TEST*
Diffstat (limited to 'sys-apps/ifplugd/ifplugd-0.15.ebuild')
-rw-r--r--sys-apps/ifplugd/ifplugd-0.15.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/ifplugd/ifplugd-0.15.ebuild b/sys-apps/ifplugd/ifplugd-0.15.ebuild
new file mode 100644
index 000000000000..8f0699f209ff
--- /dev/null
+++ b/sys-apps/ifplugd/ifplugd-0.15.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifplugd/ifplugd-0.15.ebuild,v 1.1 2003/08/06 18:00:33 wmertens Exp $
+
+DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
+HOMEPAGE="http://www.stud.uni-hamburg.de/users/lennart/projects/ifplugd"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="dev-libs/libdaemon"
+
+S=${WORKDIR}/${P}
+
+# Gentoo-provided scripts. Version is for the scripts, not ifplugd.
+INITSCRIPT=${FILESDIR}/gentoo-ifplugd-init-v2
+ACTIONSCRIPT=${FILESDIR}/gentoo-ifplugd.action-v2
+
+src_unpack() {
+ unpack ${A}
+
+ cp ${ACTIONSCRIPT} ${T}/ifplugd.action
+ cp ${INITSCRIPT} ${T}/ifplugd
+
+ cd ${S}
+ # This moves the default location for the script that handles
+ # calling the distro network scripts to /usr/sbin. The reason
+ # is that the user probably shouldn't mess with it.
+ sed -i~ 's:SYSCONFDIR"/ifplugd/:"/usr/sbin/:' src/ifplugd.c
+ # Remove the -w startup option; it gives an unwanted error return
+ sed -i~ 's/ -w//' conf/ifplugd.conf
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ use doc && dohtml doc/*.html doc/*.css
+
+ # Fix init.d configuration
+ dodir /etc/conf.d
+ cd ${D}/etc
+ # rc config file
+ mv ifplugd/ifplugd.conf conf.d/ifplugd
+ rm -rf ifplugd/
+ rm -f init.d/ifplugd
+
+ dosbin ${T}/ifplugd.action
+
+ exeinto /etc/init.d
+ doexe ${T}/ifplugd
+}