summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-25 03:04:29 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-25 03:04:29 +0000
commit90d478f82754fae0d282cc657f023c937008eec8 (patch)
tree52780541981241b59330ca9ac52c8be332c9bd51 /sys-apps/gawk
parenttemp fix, module_init_tools depends on it (diff)
downloadhistorical-90d478f82754fae0d282cc657f023c937008eec8.tar.gz
historical-90d478f82754fae0d282cc657f023c937008eec8.tar.bz2
historical-90d478f82754fae0d282cc657f023c937008eec8.zip
keyword and ebuild change
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog6
-rw-r--r--sys-apps/gawk/gawk-3.1.2.ebuild41
2 files changed, 31 insertions, 16 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index 44d74040e4ca..cf4b71cb145c 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/gawk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.14 2003/03/24 21:59:36 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.15 2003/03/25 03:04:29 lostlogic Exp $
*gawk-3.1.2 (24 Mar 2003)
24 Mar 2003; Brandon Low <lostlogic@gentoo.org> gawk-3.1.2.ebuild:
+ -* keyword, and get the -r1 ebuild stuff that I somehow ignored into it, a -r1
+ which will be ~ rather than - will be forthcoming
+
+ 24 Mar 2003; Brandon Low <lostlogic@gentoo.org> gawk-3.1.2.ebuild:
Bump
20 Feb 2003; Zach Welch <zwelch@gentoo.org> gawk-3.1.1-r1.ebuild :
diff --git a/sys-apps/gawk/gawk-3.1.2.ebuild b/sys-apps/gawk/gawk-3.1.2.ebuild
index df1d53bc0232..185142135ade 100644
--- a/sys-apps/gawk/gawk-3.1.2.ebuild
+++ b/sys-apps/gawk/gawk-3.1.2.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.2.ebuild,v 1.1 2003/03/24 21:59:36 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.2.ebuild,v 1.2 2003/03/25 03:04:29 lostlogic Exp $
IUSE="nls build"
-S=${WORKDIR}/${P}
+S="${WORKDIR}/${P}"
DESCRIPTION="GNU awk pattern-matching language"
SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gawk/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+KEYWORDS="-*"
SLOT="0"
LICENSE="GPL-2"
@@ -36,26 +37,35 @@ src_install() {
infodir=${D}/usr/share/info \
libexecdir=${D}/usr/lib/awk \
install || die
-
- cd ${D}/bin
- rm -f gawk
- ln -s gawk-${PV} gawk
+
+ # In some rare cases, gawk gets installed as gawk- and not gawk-${PV} ..
+ if [ -f ${D}/bin/gawk -a ! -f ${D}/bin/gawk-${PV} ]
+ then
+ mv -f ${D}/bin/gawk ${D}/bin/gawk-${PV}
+ elif [ -f ${D}/bin/gawk- -a ! -f ${D}/bin/gawk-${PV} ]
+ then
+ mv -f ${D}/bin/gawk ${D}/bin/gawk-${PV}
+ fi
+
+ rm -f ${D}/bin/{awk,gawk}
+ dosym gawk-${PV} /bin/awk
+ dosym gawk-${PV} /bin/gawk
#compat symlink
dodir /usr/bin
- cd ${D}/usr/bin
- ln -s /bin/gawk-${PV} awk
- ln -s /bin/gawk-${PV} gawk
+ dosym ../../bin/gawk-${PV} /usr/bin/awk
+ dosym ../../bin/gawk-${PV} /usr/bin/gawk
+
+ # Install headers
+ insinto /usr/include/awk
+ doins ${S}/*.h
- cd ${S}
if [ -z "`use build`" ]
then
dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
- dodoc ChangeLog ACKNOWLEDGMENT COPYING FUTURES
- dodoc LIMITATIONS NEWS PROBLEMS README
+ dodoc AUTHORS ChangeLog COPYING FUTURES
+ dodoc LIMITATIONS NEWS PROBLEMS POSIX.STD README
docinto README_d
dodoc README_d/*
- docinto atari
- dodoc atari/ChangeLog atari/README.1st
docinto awklib
dodoc awklib/ChangeLog
docinto pc
@@ -66,3 +76,4 @@ src_install() {
rm -rf ${D}/usr/share
fi
}
+