summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-10-16 08:02:15 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-10-16 08:02:15 +0000
commit1c2ddbd7e6fc993ce3a3c96613c54ad11ba0b9e5 (patch)
treea234a6cf7ab54db635170033c6cf4d97434cf283 /sys-apps/galago-daemon/galago-daemon-0.5.1.ebuild
parentversion bump from upstream (diff)
downloadhistorical-1c2ddbd7e6fc993ce3a3c96613c54ad11ba0b9e5.tar.gz
historical-1c2ddbd7e6fc993ce3a3c96613c54ad11ba0b9e5.tar.bz2
historical-1c2ddbd7e6fc993ce3a3c96613c54ad11ba0b9e5.zip
version bump from upstream
Package-Manager: portage-2.1.2_pre3-r1
Diffstat (limited to 'sys-apps/galago-daemon/galago-daemon-0.5.1.ebuild')
-rw-r--r--sys-apps/galago-daemon/galago-daemon-0.5.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/galago-daemon/galago-daemon-0.5.1.ebuild b/sys-apps/galago-daemon/galago-daemon-0.5.1.ebuild
new file mode 100644
index 000000000000..f7ec9c70de5a
--- /dev/null
+++ b/sys-apps/galago-daemon/galago-daemon-0.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/galago-daemon/galago-daemon-0.5.1.ebuild,v 1.1 2006/10/16 08:02:15 compnerd Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Galago presence daemon"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libgalago-0.5.2
+ >=sys-apps/dbus-0.36"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ test? ( dev-libs/check )"
+
+src_compile() {
+ econf $(use_enable test tests) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}