summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2003-08-11 18:24:35 +0000
committerAlexander Gabert <pappy@gentoo.org>2003-08-11 18:24:35 +0000
commitb720f1726d3358ceb239e50a12e709f81e531899 (patch)
treec454b793ccfb659d522c67abd1d5dca59ccd0a32 /sys-apps/file
parentfile command segfaults on hppa when pa8000 schedule for gcc is used (diff)
downloadhistorical-b720f1726d3358ceb239e50a12e709f81e531899.tar.gz
historical-b720f1726d3358ceb239e50a12e709f81e531899.tar.bz2
historical-b720f1726d3358ceb239e50a12e709f81e531899.zip
file command segfaults on hppa when pa8000 schedule for gcc is used
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest4
-rw-r--r--sys-apps/file/file-4.02.ebuild8
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index 6645c76574ba..a0e3b7aa5868 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -1,9 +1,9 @@
-MD5 1639199c3b4a99f635ea10d267e72059 ChangeLog 2563
+MD5 e7aa8fc29e19a910747ba7c190b28ed7 ChangeLog 2562
MD5 9199c0027f82ae3e018e2415de888492 file-3.37.ebuild 870
MD5 0489e4ec24edc82bb4835f5f0101a192 file-3.39.ebuild 1034
MD5 864d9d78ae48573d790cc598fcc4bc40 file-3.41.ebuild 1025
MD5 7530c9f704120047896981d3d53a47eb file-4.01.ebuild 938
-MD5 695a1c8b5a3908435d6f38b56424ea96 file-4.02.ebuild 1093
+MD5 b73bc887b8b38d7a8cbdbaf03db293aa file-4.02.ebuild 1092
MD5 3a18c97dfcc727e6c1b701cc8c03af47 files/digest-file-3.37 267
MD5 950dd57055e8275bd852869557035f42 files/digest-file-3.39 268
MD5 eabc698678353b52ea7d9bfb724d4e1e files/digest-file-3.41 268
diff --git a/sys-apps/file/file-4.02.ebuild b/sys-apps/file/file-4.02.ebuild
index ba7b3601efaf..97d28e9d8894 100644
--- a/sys-apps/file/file-4.02.ebuild
+++ b/sys-apps/file/file-4.02.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.02.ebuild,v 1.6 2003/07/06 14:12:14 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.02.ebuild,v 1.7 2003/08/11 18:24:23 pappy Exp $
+
+inherit flag-o-matic
S=${WORKDIR}/${P}
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
@@ -15,6 +17,10 @@ LICENSE="as-is"
DEPEND="virtual/glibc"
src_compile() {
+
+ # file command segfaults on hppa - reported by gustavo@zacarias.com.ar
+ [ ${ARCH} = "hppa" ] && filter-flags "-mschedule=8000"
+
./configure --prefix=/usr \
--mandir=/usr/share/man \
--datadir=/usr/share/misc \