summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-03-11 22:13:01 +0000
committerPeter Gavin <pete@gentoo.org>2001-03-11 22:13:01 +0000
commit524779681647ee15e0f74d57b9528a324c434b6c (patch)
tree0eb7c0bcc7255e27b8f4d742af644816d3b03dcb /sys-apps/eject
parentfixum (diff)
downloadhistorical-524779681647ee15e0f74d57b9528a324c434b6c.tar.gz
historical-524779681647ee15e0f74d57b9528a324c434b6c.tar.bz2
historical-524779681647ee15e0f74d57b9528a324c434b6c.zip
added ttmkfdir and eject-2.0.2
Diffstat (limited to 'sys-apps/eject')
-rw-r--r--sys-apps/eject/eject-2.0.2.ebuild29
-rw-r--r--sys-apps/eject/files/digest-eject-2.0.21
-rw-r--r--sys-apps/eject/files/eject-2.0.2-gentoo.diff66
3 files changed, 96 insertions, 0 deletions
diff --git a/sys-apps/eject/eject-2.0.2.ebuild b/sys-apps/eject/eject-2.0.2.ebuild
new file mode 100644
index 000000000000..216d9c3c17f6
--- /dev/null
+++ b/sys-apps/eject/eject-2.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.0.2.ebuild,v 1.1 2001/03/11 22:13:01 pete Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION=""
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/disk-management/${A}"
+HOMEPAGE="http://www.pobox.com/~tranter/eject.html"
+
+DEPEND="virtual/glibc
+ virtual/kernel"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ try make OPT=\""${CFLAGS}"\"
+}
+
+src_install () {
+ dodir /usr/bin /usr/share/man/man1
+ try make DESTDIR=${D} install
+}
diff --git a/sys-apps/eject/files/digest-eject-2.0.2 b/sys-apps/eject/files/digest-eject-2.0.2
new file mode 100644
index 000000000000..d017f831fa2d
--- /dev/null
+++ b/sys-apps/eject/files/digest-eject-2.0.2
@@ -0,0 +1 @@
+MD5 70a6644dd85623cda100f552a1fe0480 eject-2.0.2.tar.gz
diff --git a/sys-apps/eject/files/eject-2.0.2-gentoo.diff b/sys-apps/eject/files/eject-2.0.2-gentoo.diff
new file mode 100644
index 000000000000..9949d73a4220
--- /dev/null
+++ b/sys-apps/eject/files/eject-2.0.2-gentoo.diff
@@ -0,0 +1,66 @@
+diff -ur eject-2.0.2.orig/Makefile eject-2.0.2/Makefile
+--- eject-2.0.2.orig/Makefile Sun Feb 14 15:49:02 1999
++++ eject-2.0.2/Makefile Thu Mar 1 21:52:09 2001
+@@ -1,24 +1,28 @@
+ # Make file for eject
+
++DESTDIR=
++
+ # Default device to eject. Can be a partial name such as "cdrom" or
+ # a full device name such as "/dev/sda4".
+ DEFAULTDEVICE = \"cdrom\"
+
+ # Location to install binary. Default is /usr/local/bin. You may
+ # prefer to install it in /usr/bin or /sbin
+-BINDIR = /usr/local/bin
+-#BINDIR=/usr/bin
++#BINDIR = /usr/local/bin
++BINDIR=/usr/bin
+ #BINDIR=/usr/sbin
+
+ # Location to install man page. Default is /usr/local/man. You may
+ # prefer to install it in /usr/man
+-MANDIR = /usr/local/man
++#MANDIR = /usr/local/man
+ #MANDIR = /usr/man
++MANDIR = /usr/share/man
+
+ # File permissions for binary. Use MODE=4555 if you want to install it
+ # setuid root (see man page).
+-MODE = 555
++#MODE = 555
+ #MODE = 4555
++MODE = 755
+
+ # Compiler to use
+ CC = gcc
+@@ -29,14 +33,15 @@
+ # Preprocessor options
+ # Define -DGETOPTLONG if you have GNU getopt_long()
+ # -I options are needed for some systems that do not have /usr/include/scsi
+-CPPFLAGS = -I/usr/src/linux -I/usr/src/linux/include -DDEFAULTDEVICE=$(DEFAULTDEVICE) -DGETOPTLONG
++CPPFLAGS = -DDEFAULTDEVICE=$(DEFAULTDEVICE) -DGETOPTLONG
+
+ # Compile and link options
+ # On a.out systems you might want to add -N when linking
+ # RPM_OPT_FLAGS can be set by rpm tool
+ # ...For production code
+-CFLAGS = -Wall -O3 $(RPM_OPT_FLAGS)
+-LDFLAGS = -s
++OPT=-O2
++CFLAGS = -Wall $(OPT)
++LDFLAGS =
+ # ...For debug
+ #CFLAGS = -Wall -g
+ #LDFLAGS = -g
+@@ -48,8 +53,8 @@
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c eject.c
+
+ install: eject
+- install -m $(MODE) eject $(BINDIR)/eject
+- install -m 444 eject.1 $(MANDIR)/man1/eject.1
++ install -m $(MODE) eject $(DESTDIR)/$(BINDIR)/eject
++ install -m 644 eject.1 $(DESTDIR)/$(MANDIR)/man1/eject.1
+ @for dir in /bin /usr/bin /sbin /usr/sbin /usr/local/bin /usr/local/sbin ; do \
+ test $(BINDIR) = $$dir && continue ; \
+ if [ -x $$dir/eject ] ; then \