summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-06-11 03:40:20 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-06-11 03:40:20 +0000
commitdb13186d5943d82cf1e83bb35271516d46ee8d94 (patch)
tree8e594432503aa13ffc84ea4222be918c7cda766e /sys-apps/devfsd
parentsome new stuff from moath. (diff)
downloadhistorical-db13186d5943d82cf1e83bb35271516d46ee8d94.tar.gz
historical-db13186d5943d82cf1e83bb35271516d46ee8d94.tar.bz2
historical-db13186d5943d82cf1e83bb35271516d46ee8d94.zip
devfs is now enabled by default; baselayout no longer creates device entries
Diffstat (limited to 'sys-apps/devfsd')
-rw-r--r--sys-apps/devfsd/devfsd-1.3.11-r1.ebuild (renamed from sys-apps/devfsd/devfsd-1.3.11.ebuild)33
-rwxr-xr-xsys-apps/devfsd/files/devfsd13
-rw-r--r--sys-apps/devfsd/files/devfsd.conf34
3 files changed, 50 insertions, 30 deletions
diff --git a/sys-apps/devfsd/devfsd-1.3.11.ebuild b/sys-apps/devfsd/devfsd-1.3.11-r1.ebuild
index 50df5acac717..376248db5666 100644
--- a/sys-apps/devfsd/devfsd-1.3.11.ebuild
+++ b/sys-apps/devfsd/devfsd-1.3.11-r1.ebuild
@@ -1,39 +1,32 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/devfsd/devfsd-1.3.11.ebuild,v 1.3 2001/04/24 16:58:44 achim Exp $
+# Author Daniel Robbins et al <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/devfsd/devfsd-1.3.11-r1.ebuild,v 1.1 2001/06/11 03:40:20 drobbins Exp $
S=${WORKDIR}/${PN}
-DESCRIPTION="Daemon for the Lunx Device Filesystem"
+DESCRIPTION="Daemon for the Linux Device Filesystem"
SRC_URI="ftp://ftp.atnf.csiro.au/pub/people/rgooch/linux/daemons/devfsd/devfsd-v${PV}.tar.gz"
HOMEPAGE="http://www.atnf.csiro.au/~rgooch/linux/"
src_unpack() {
-
- unpack ${A}
- cd ${S}
- patch -p0 < ${FILESDIR}/${P}-GNUmakefile-gentoo.diff
-
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-GNUmakefile-gentoo.diff
}
src_compile() {
-
- try make
+ try make
}
src_install () {
-
- try make DESTDIR=${D} install
-
- exeinto /etc/rc.d/init.d
- doexe ${FILESDIR}/devfsd
- dodir /etc/devfs/shm
-
+ try make DESTDIR=${D} install
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/devfsd
+ dodir /etc/devfs/shm
+ insinto /etc
+ doins ${FILESDIR}/devfsd.conf
}
pkg_postinst () {
-
- rc-update add devfsd
-
+ rc-update add devfsd
}
diff --git a/sys-apps/devfsd/files/devfsd b/sys-apps/devfsd/files/devfsd
index 72cae3383ab7..71afbdd55a08 100755
--- a/sys-apps/devfsd/files/devfsd
+++ b/sys-apps/devfsd/files/devfsd
@@ -6,15 +6,8 @@
. /etc/rc.d/config/functions
# Test if we use devfs and start devfsd
-/sbin/devfsd /dev
+mount --bind /dev /dev-state
+mount -t devfs none /dev
+//sbin/devfsd /dev
-if [ -a /dev/.devfsd ]
-then
- if [ -d /etc/devfs ]
- then
- ebegin "Restoring devices..."
- /bin/cp -a /etc/devfs/* /dev
- eend 0
- fi
-fi
diff --git a/sys-apps/devfsd/files/devfsd.conf b/sys-apps/devfsd/files/devfsd.conf
new file mode 100644
index 000000000000..1c50dc53db0b
--- /dev/null
+++ b/sys-apps/devfsd/files/devfsd.conf
@@ -0,0 +1,34 @@
+# Sample /etc/devfsd.conf configuration file.
+# Richard Gooch <rgooch@atnf.csiro.au> 3-JUL-2000
+#
+# Enable full compatibility mode for old device names. You may comment these
+# out if you don't use the old device names. Make sure you know what you're
+# doing!
+REGISTER .* MKOLDCOMPAT
+UNREGISTER .* RMOLDCOMPAT
+
+# You may comment out the above and uncomment the following if you've
+# configured your system to use the original "new" devfs names or the really
+# new names
+#REGISTER vc/.* MKOLDCOMPAT
+#UNREGISTER vc/.* RMOLDCOMPAT
+#REGISTER pty/.* MKOLDCOMPAT
+#UNREGISTER pty/.* RMOLDCOMPAT
+#REGISTER misc MKOLDCOMPAT
+#UNREGISTER misc RMOLDCOMPAT
+
+# You may comment these out if you don't use the original "new" names
+REGISTER .* MKNEWCOMPAT
+UNREGISTER .* RMNEWCOMPAT
+
+# Enable module autoloading. You may comment this out if you don't use
+# autoloading
+LOOKUP .* MODLOAD
+
+# Uncomment this if you want permissions to be saved and restored
+REGISTER ^pt[sy]/.* IGNORE
+CHANGE ^pt[sy]/.* IGNORE
+REGISTER .* COPY /dev-state/$devname $devpath
+CHANGE .* COPY $devpath /dev-state/$devname
+CREATE .* COPY $devpath /dev-state/$devname
+