summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-12-26 12:48:24 +0000
committerAchim Gottinger <achim@gentoo.org>2000-12-26 12:48:24 +0000
commit35b59c2b56c91bb173cd8c0344621e044a133a94 (patch)
treebb3aea07ab706dd6f1d19a1d3505d4ce6026b0fd /sys-apps/devfsd
parenttesting out python 2.0 (diff)
downloadhistorical-35b59c2b56c91bb173cd8c0344621e044a133a94.tar.gz
historical-35b59c2b56c91bb173cd8c0344621e044a133a94.tar.bz2
historical-35b59c2b56c91bb173cd8c0344621e044a133a94.zip
This daemon is required to use the old /dev syntax together with the
new devfs
Diffstat (limited to 'sys-apps/devfsd')
-rw-r--r--sys-apps/devfsd/devfsd-1.3.10.ebuild32
-rw-r--r--sys-apps/devfsd/files/devfsd.h34
-rw-r--r--sys-apps/devfsd/files/digest-devfsd-1.3.101
3 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/devfsd/devfsd-1.3.10.ebuild b/sys-apps/devfsd/devfsd-1.3.10.ebuild
new file mode 100644
index 000000000000..c745ff140a57
--- /dev/null
+++ b/sys-apps/devfsd/devfsd-1.3.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/devfsd/devfsd-1.3.10.ebuild,v 1.1 2000/12/26 12:48:24 achim Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Daemon for the Lunx Device Filesystem"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/people/rgooch/linux/daemons/devfsd/devfsd-v1.3.10.tar.gz"
+HOMEPAGE="http://www.atnf.csiro.au/~rgooch/linux/"
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/devfsd.h ${S}
+}
+
+src_compile() {
+
+ cd ${S}
+ try make
+
+}
+
+src_install () {
+
+ into /
+ dosbin devfsd
+ into /usr
+ doman devfsd.8
+ insinto /etc
+ doins devfsd.conf modules.devfs
+}
+
diff --git a/sys-apps/devfsd/files/devfsd.h b/sys-apps/devfsd/files/devfsd.h
new file mode 100644
index 000000000000..129f367d8d73
--- /dev/null
+++ b/sys-apps/devfsd/files/devfsd.h
@@ -0,0 +1,34 @@
+/* devfsd.h
+
+ Header file for devfsd (devfs daemon for Linux).
+
+ Copyright (C) 1998-2000 Richard Gooch
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+ Richard Gooch may be reached by email at rgooch@atnf.csiro.au
+ The postal address is:
+ Richard Gooch, c/o ATNF, P. O. Box 76, Epping, N.S.W., 2121, Australia.
+*/
+
+#define SYSLOG(level, format, args...) \
+ {if (syslog_is_open) syslog (level, format, ##args); \
+ else fprintf (stderr, format, ## args);}
+
+
+/* Public data */
+extern flag syslog_is_open; /* File: devfsd.c */
+
+#define RTLD_NEXT ((void *) -1l) \ No newline at end of file
diff --git a/sys-apps/devfsd/files/digest-devfsd-1.3.10 b/sys-apps/devfsd/files/digest-devfsd-1.3.10
new file mode 100644
index 000000000000..5777a069d6f8
--- /dev/null
+++ b/sys-apps/devfsd/files/digest-devfsd-1.3.10
@@ -0,0 +1 @@
+MD5 2e82cf69ae4ef7a32161a98bb4a67c21 devfsd-v1.3.10.tar.gz