summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
commit20679156a1fa704fec1fab5a9c8693166c701bca (patch)
treea62659954140718f26c91857fb2cd8e2ff4c5217 /sys-apps/devfsd
parent*** empty log message *** (diff)
downloadhistorical-20679156a1fa704fec1fab5a9c8693166c701bca.tar.gz
historical-20679156a1fa704fec1fab5a9c8693166c701bca.tar.bz2
historical-20679156a1fa704fec1fab5a9c8693166c701bca.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-apps/devfsd')
-rw-r--r--sys-apps/devfsd/devfsd-1.3.11.ebuild44
-rw-r--r--sys-apps/devfsd/files/digest-devfsd-1.3.111
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/devfsd/devfsd-1.3.11.ebuild b/sys-apps/devfsd/devfsd-1.3.11.ebuild
new file mode 100644
index 000000000000..29ad35150794
--- /dev/null
+++ b/sys-apps/devfsd/devfsd-1.3.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/devfsd/devfsd-1.3.11.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Daemon for the Lunx Device Filesystem"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/people/rgooch/linux/daemons/devfsd/devfsd-v${PV}.tar.gz"
+HOMEPAGE="http://www.atnf.csiro.au/~rgooch/linux/"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ ls
+ cp GNUmakefile GNUmakefile.orig
+ sed -e "s:-O2:${CFLAGS}:" GNUmakefile.orig > GNUmakefile
+
+}
+
+src_compile() {
+
+ try make
+}
+
+src_install () {
+
+ into /
+ dosbin devfsd
+ into /usr
+ doman devfsd.8
+ insinto /etc
+ doins devfsd.conf modules.devfs
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/devfsd
+
+}
+
+pkg_postinst () {
+
+ rc-update add devfsd
+
+}
+
diff --git a/sys-apps/devfsd/files/digest-devfsd-1.3.11 b/sys-apps/devfsd/files/digest-devfsd-1.3.11
new file mode 100644
index 000000000000..e219fc6f4935
--- /dev/null
+++ b/sys-apps/devfsd/files/digest-devfsd-1.3.11
@@ -0,0 +1 @@
+MD5 8bbd8558ee83a625a404c6069b66d4e0 devfsd-v1.3.11.tar.gz