summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-12 18:01:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-12 18:01:10 +0000
commitd43b6fdd18be17aa158be8f764c0ff61a0832d51 (patch)
tree5e97554287550fd187f40ba1f5293dcc064a0c75 /sys-apps/cpudyn
parentouch, forgot this one, removed because of buffer overflows (diff)
downloadhistorical-d43b6fdd18be17aa158be8f764c0ff61a0832d51.tar.gz
historical-d43b6fdd18be17aa158be8f764c0ff61a0832d51.tar.bz2
historical-d43b6fdd18be17aa158be8f764c0ff61a0832d51.zip
dont require all govners to be present #67242
Diffstat (limited to 'sys-apps/cpudyn')
-rw-r--r--sys-apps/cpudyn/Manifest8
-rw-r--r--sys-apps/cpudyn/files/cpudyn.init17
2 files changed, 7 insertions, 18 deletions
diff --git a/sys-apps/cpudyn/Manifest b/sys-apps/cpudyn/Manifest
index bc26f5705377..227751430287 100644
--- a/sys-apps/cpudyn/Manifest
+++ b/sys-apps/cpudyn/Manifest
@@ -6,13 +6,13 @@ MD5 b82d65788ad9b14893f23d69e6ef6322 cpudyn-1.0.ebuild 986
MD5 2c60519258a78ccd06d3bfe30cb50e73 cpudyn-0.99.0.ebuild 1071
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 18c8ec21370d4ce089720fe94de89e6c files/digest-cpudyn-1.0 58
-MD5 f3715f690956055ae4729d283278d613 files/cpudyn.init 3430
+MD5 0856b699f523f97c7618f07b8e146e77 files/cpudyn.init 3034
MD5 1d3f888c7c5af12d57517e8c7ebb27d8 files/cpudyn-0.99.0-init_conf_updates.patch 816
MD5 14510794829fd0435f8342da60c5ba46 files/digest-cpudyn-0.99.0 61
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBaNnVHTu7gpaalycRAsDKAJ9oia9clXJ4NtYeYJSk8QRIcq+9dACgteSI
-cB7yl7DON9JQ92ka8nZWjnQ=
-=/+gm
+iD8DBQFBbBv7HTu7gpaalycRAgxLAJ9L8b3FY1Tx2EIS1sjW8elMfYktCwCeNFXS
+g38jBX+rphjE8eBGsjpmkkk=
+=ub83
-----END PGP SIGNATURE-----
diff --git a/sys-apps/cpudyn/files/cpudyn.init b/sys-apps/cpudyn/files/cpudyn.init
index 9ad3f2ddd7ba..ab4d530f33ce 100644
--- a/sys-apps/cpudyn/files/cpudyn.init
+++ b/sys-apps/cpudyn/files/cpudyn.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpudyn/files/cpudyn.init,v 1.5 2004/10/10 06:42:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpudyn/files/cpudyn.init,v 1.6 2004/10/12 18:01:10 vapier Exp $
#
# Based on the Debian init script written by Celso Gonzalez <celso@bulma.net>,
# and on the cpufreqd Gentoo init script written by Robert Gogolok <robertgogolok@web.de>.
@@ -49,19 +49,8 @@ checkconfig() {
# Silently try to load the governors; shouldn't hurt if they're already there
modprobe -q cpufreq_performance
modprobe -q cpufreq_powersave
- # Check that all governors required are actually present
- missing=""
- for x in userspace performance powersave ; do
- if [ -z "$(grep ${x} ${CPUFREQ_FILE}/scaling_available_governors)" ]; then
- missing="${missing} ${x}"
- fi
- done
- # If some are missing, report which, then bail
- if [ ! -z "${missing}" ]; then
- eerror "2.5/2.6 CPUfreq support needs userspace, performance and powersave governors"
- eerror "Missing${missing}"
- return 1
- fi
+ modprobe -q cpufreq_userspace
+ modprobe -q cpufreq_ondemand
fi
}