summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-23 04:40:20 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-23 04:40:20 +0000
commitaa948608a05b6019833b007ae898a77be0295e91 (patch)
tree8c1618f8bfa38eb929668eb3cf9f172ef135d3d6 /sys-apps/coreutils
parentsys-apps/coreutils-6.10-r1 and higher now provides /bin/mktemp (diff)
downloadhistorical-aa948608a05b6019833b007ae898a77be0295e91.tar.gz
historical-aa948608a05b6019833b007ae898a77be0295e91.tar.bz2
historical-aa948608a05b6019833b007ae898a77be0295e91.zip
old
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/coreutils-6.10.ebuild147
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-6.106
2 files changed, 0 insertions, 153 deletions
diff --git a/sys-apps/coreutils/coreutils-6.10.ebuild b/sys-apps/coreutils/coreutils-6.10.ebuild
deleted file mode 100644
index 2f71e6f7b852..000000000000
--- a/sys-apps/coreutils/coreutils-6.10.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.10.ebuild,v 1.1 2008/01/23 00:07:06 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs autotools
-
-PATCH_VER="1.0"
-DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
-HOMEPAGE="http://www.gnu.org/software/coreutils/"
-SRC_URI="ftp://alpha.gnu.org/gnu/coreutils/${P}.tar.lzma
- mirror://gnu/${PN}/${P}.tar.lzma
- mirror://gentoo/${P}.tar.lzma
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
- http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="acl nls selinux static xattr"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )
- nls? ( >=sys-devel/gettext-0.15 )
- !net-mail/base64
- >=sys-libs/ncurses-5.3-r5"
-DEPEND="${RDEPEND}
- app-arch/lzma-utils
- >=sys-devel/automake-1.10.1
- >=sys-devel/autoconf-2.61
- >=sys-devel/m4-1.4-r1"
-
-pkg_setup() {
- # fixup expr for #123342
- if [[ $(/bin/expr a : '\(a\)') != "a" ]] ; then
- if [[ -x /bin/busybox ]] ; then
- ln -sf /bin/busybox /bin/expr
- else
- eerror "Your expr binary appears to be broken, please fix it."
- eerror "For more info, see http://bugs.gentoo.org/123342"
- die "your expr is broke"
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- EPATCH_SUFFIX="patch" \
- PATCHDIR="${WORKDIR}/patch" \
- EPATCH_EXCLUDE="001_all_coreutils-gen-progress-bar.patch" \
- epatch
-
- # Since we've patched many .c files, the make process will try to
- # re-build the manpages by running `./bin --help`. When doing a
- # cross-compile, we can't do that since 'bin' isn't a native bin.
- # Also, it's not like we changed the usage on any of these things,
- # so let's just update the timestamps and skip the help2man step.
- touch man/*.1
- # There's no reason for this crap to use the private version
- sed -i 's:__mempcpy:mempcpy:g' lib/*.c
-
- AT_M4DIR="m4" eautoreconf
-}
-
-src_compile() {
- if ! type -p cvs > /dev/null ; then
- # Fix issues with gettext's autopoint if cvs is not installed,
- # bug #28920.
- export AUTOPOINT="/bin/true"
- fi
-
- local myconf=""
- [[ ${USERLAND} == "GNU" ]] || myconf="${myconf} --bindir=/usr/libexec/gnu"
- if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
- myconf="${myconf} --without-included-regex"
- fi
-
- # cross-compile workaround #177061
- [[ ${CHOST} == *-linux* ]] && export fu_cv_sys_stat_statvfs=yes
-
- use static && append-ldflags -static
- # kill/uptime - procps
- # groups/su - shadow
- # hostname - net-tools
- econf \
- --enable-install-program="arch" \
- --enable-no-install-program="groups,hostname,kill,su,uptime" \
- --enable-largefile \
- $(use_enable nls) \
- $(use_enable acl) \
- $(use_enable xattr) \
- $(use_enable selinux) \
- ${myconf} \
- || die "econf"
- emake || die "emake"
-}
-
-src_test() {
- # Non-root tests will fail if the full path isnt
- # accessible to non-root users
- chmod -R go-w "${WORKDIR}"
- chmod a+rx "${WORKDIR}"
- addwrite /dev/full
- export RUN_EXPENSIVE_TESTS="yes"
- #export FETISH_GROUPS="portage wheel"
- make -k check || die "make check failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- rm -f "${D}"/usr/lib/charset.alias
- dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
-
- insinto /etc
- newins src/dircolors.hin DIR_COLORS || die
-
- # workaround bug in build system where `group` does not
- # work with --enable-no-install-program configure option
- rm "${D}"/usr/bin/groups "${D}"/usr/share/man/man1/groups.1 || die
-
- if [[ ${USERLAND} == "GNU" ]] ; then
- cd "${D}"/usr/bin
- dodir /bin
- # move critical binaries into /bin (required by FHS)
- local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
- mkdir mknod mv pwd rm rmdir stty sync true uname"
- mv ${fhs} ../../bin/ || die "could not move fhs bins"
- # move critical binaries into /bin (common scripts)
- local com="basename chroot cut dir dirname du env expr head mkfifo
- readlink seq sleep sort tail touch tr tty vdir wc yes"
- mv ${com} ../../bin/ || die "could not move common bins"
- # create a symlink for uname in /usr/bin/ since autotools require it
- local x
- for x in ${com} uname ; do
- dosym /bin/${x} /usr/bin/${x} || die
- done
- else
- # For now, drop the man pages, collides with the ones of the system.
- rm -rf "${D}"/usr/share/man
- fi
-}
-
-pkg_postinst() {
- ewarn "Make sure you run 'hash -r' in your active shells."
-}
diff --git a/sys-apps/coreutils/files/digest-coreutils-6.10 b/sys-apps/coreutils/files/digest-coreutils-6.10
deleted file mode 100644
index a4d8efaddf26..000000000000
--- a/sys-apps/coreutils/files/digest-coreutils-6.10
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 46e83f0013134e1edf2f0c0495a9dc53 coreutils-6.10-patches-1.0.tar.bz2 10046
-RMD160 7de54627e3abdef594dc786af441db0206c8dff5 coreutils-6.10-patches-1.0.tar.bz2 10046
-SHA256 6e5fc6be92f932a9c4b2c04d8f008a66bb6b12eae608b8bf629cbe0b0eb1bafd coreutils-6.10-patches-1.0.tar.bz2 10046
-MD5 23582a4e8b21e837cfbafbc3834a8a4b coreutils-6.10.tar.lzma 3746908
-RMD160 7b3f7ae0f92fa3f04ab0b7fc0bbc22430a392a0b coreutils-6.10.tar.lzma 3746908
-SHA256 8b05bba1b2726a164e444c314e3f359604b58216be704bed8f2e028449cc6204 coreutils-6.10.tar.lzma 3746908