summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-07 08:35:49 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-07 08:35:49 +0000
commitfc484e1d1e3a518efea55c48e5ee9a62f3343ead (patch)
tree168554828081aa8d93977efdbca893d68901f3f6 /sys-apps/acpid/acpid-1.0.2-r1.ebuild
parentno optimisations (diff)
downloadhistorical-fc484e1d1e3a518efea55c48e5ee9a62f3343ead.tar.gz
historical-fc484e1d1e3a518efea55c48e5ee9a62f3343ead.tar.bz2
historical-fc484e1d1e3a518efea55c48e5ee9a62f3343ead.zip
no optimisations
Diffstat (limited to 'sys-apps/acpid/acpid-1.0.2-r1.ebuild')
-rw-r--r--sys-apps/acpid/acpid-1.0.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/acpid/acpid-1.0.2-r1.ebuild b/sys-apps/acpid/acpid-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..8a31637c87d3
--- /dev/null
+++ b/sys-apps/acpid/acpid-1.0.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.2-r1.ebuild,v 1.1 2003/06/07 08:35:47 seemant Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface."
+SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+HOMEPAGE="http://acpid.sourceforge.net/"
+IUSE=""
+KEYWORDS="~x86 -ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+# We need the patched kernel with latest ACPI code, or else it will
+# be broken. Hopefully it will be merge into release kernel soon.
+DEPEND="virtual/glibc
+ virtual/linux-sources"
+
+src_compile() {
+
+ # DO NOT COMPILE WITH OPTIMISATIONS.
+ # That is a note to the devs. IF you are a user, go ahead and optimise
+ # if you want, but we won't support bugs associated with that"
+ make INSTPREFIX=${D} || die
+}
+
+src_install() {
+ make INSTPREFIX=${D} install || die
+
+ dodir /etc/acpi/events
+ exeinto /etc/acpi
+ doexe debian/default.sh
+ insinto /etc/acpi/events
+ doins debian/default
+
+ dodoc README Changelog
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/acpid.rc6 acpid
+}
+