summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-02 22:52:53 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-02 22:52:53 +0000
commit6db320646ea577f30bfb45c015952a66bb2da529 (patch)
tree02f377d1b12b3f2614291416194188be51468087 /sys-apps/acl
parentAdded missing eutils eclass to inherit line. (diff)
downloadhistorical-6db320646ea577f30bfb45c015952a66bb2da529.tar.gz
historical-6db320646ea577f30bfb45c015952a66bb2da529.tar.bz2
historical-6db320646ea577f30bfb45c015952a66bb2da529.zip
Version bump.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/ChangeLog9
-rw-r--r--sys-apps/acl/acl-2.2.31.ebuild53
-rw-r--r--sys-apps/acl/files/digest-acl-2.2.311
3 files changed, 61 insertions, 2 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index 6eebed5d9df9..3f345ec1d50e 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/acl
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.41 2005/03/10 05:27:08 vapier Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.42 2005/09/02 22:52:53 vapier Exp $
+
+*acl-2.2.31 (02 Sep 2005)
+
+ 02 Sep 2005; Mike Frysinger <vapier@gentoo.org> +acl-2.2.31.ebuild:
+ Version bump.
10 Mar 2005; Mike Frysinger <vapier@gentoo.org>
+files/acl-2.2.27-nls.patch, acl-2.2.27.ebuild:
diff --git a/sys-apps/acl/acl-2.2.31.ebuild b/sys-apps/acl/acl-2.2.31.ebuild
new file mode 100644
index 000000000000..aea69db3db95
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.31.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.31.ebuild,v 1.1 2005/09/02 22:52:53 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Access control list utilities, libraries and headers"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls debug"
+
+RDEPEND=">=sys-apps/attr-2.4
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+}
+
+src_compile() {
+ if use debug ; then
+ export DEBUG=-DDEBUG
+ else
+ export DEBUG=-DNDEBUG
+ fi
+ export OPTIMIZER="${CFLAGS}"
+
+ econf \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --libexecdir=/usr/$(get_libdir) \
+ --libdir=/$(get_libdir) \
+ --bindir=/bin \
+ $(use_enable nls gettext) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install install-dev install-lib || die
+ dodoc README
+}
diff --git a/sys-apps/acl/files/digest-acl-2.2.31 b/sys-apps/acl/files/digest-acl-2.2.31
new file mode 100644
index 000000000000..154456f4a91d
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-2.2.31
@@ -0,0 +1 @@
+MD5 7e7ec2685b44d61cc68b703dac2fc453 acl-2.2.31.src.tar.gz 147595