summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-15 17:17:20 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-15 17:17:20 +0000
commit59f09d1b1e63749004ed9ab2476cd3e1f1615f23 (patch)
treef6e23cfefffbbbfd968927380654ce8da7d7d062 /sys-apps/acl
parentMoved from net-www/mod_mono to www-apache/mod_mono (diff)
downloadhistorical-59f09d1b1e63749004ed9ab2476cd3e1f1615f23.tar.gz
historical-59f09d1b1e63749004ed9ab2476cd3e1f1615f23.tar.bz2
historical-59f09d1b1e63749004ed9ab2476cd3e1f1615f23.zip
added CONF_LIBDIR support
Diffstat (limited to 'sys-apps/acl')
-rw-r--r--sys-apps/acl/ChangeLog5
-rw-r--r--sys-apps/acl/Manifest4
-rw-r--r--sys-apps/acl/acl-2.2.13-r2.ebuild22
3 files changed, 20 insertions, 11 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index e54f902a1b13..c7b98a16702e 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/acl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.31 2004/07/19 02:41:48 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.32 2004/08/15 17:17:20 lv Exp $
+
+ 15 Aug 2004; Travis Tilley <lv@gentoo.org> acl-2.2.13-r2.ebuild:
+ made acl CONF_LIBDIR aware for installing to lib64/lib32
18 Jul 2004; Robin H. Johnson <robbat2@gentoo.org> acl-2.2.13-r2.ebuild:
stable on x86.
diff --git a/sys-apps/acl/Manifest b/sys-apps/acl/Manifest
index 8eb12ca7f5e4..f89085eee054 100644
--- a/sys-apps/acl/Manifest
+++ b/sys-apps/acl/Manifest
@@ -1,6 +1,6 @@
MD5 cec4a3f0224670760af9981f5542608c acl-2.2.13-r1.ebuild 1444
-MD5 e478b8f0ad8689b77bc3b41bd5981b81 ChangeLog 4496
+MD5 5f2b2005fc93724f202e1aa44289321f ChangeLog 4618
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 857a434a950cc87de3526a96fa97fd8e acl-2.2.13-r2.ebuild 1484
+MD5 99b291a8aea56b7924a4e14fc791655c acl-2.2.13-r2.ebuild 1779
MD5 ebb544ef383bcd9ab77497e414a31528 files/digest-acl-2.2.13-r1 66
MD5 ebb544ef383bcd9ab77497e414a31528 files/digest-acl-2.2.13-r2 66
diff --git a/sys-apps/acl/acl-2.2.13-r2.ebuild b/sys-apps/acl/acl-2.2.13-r2.ebuild
index 552efbf00d45..e585de8ca0ab 100644
--- a/sys-apps/acl/acl-2.2.13-r2.ebuild
+++ b/sys-apps/acl/acl-2.2.13-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.13-r2.ebuild,v 1.15 2004/07/19 02:41:48 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.13-r2.ebuild,v 1.16 2004/08/15 17:17:20 lv Exp $
DESCRIPTION="Access control list utilities, libraries and headers"
HOMEPAGE="http://oss.sgi.com/projects/xfs"
@@ -25,12 +25,15 @@ src_compile() {
use s390 && unset PLATFORM
autoconf || die
+ [ -z "${CONF_LIBDIR}" ] && local mylibdir="lib"
+ [ ! -z "${CONF_LIBDIR}" ] && local mylibdir=${CONF_LIBDIR}
+
./configure \
`use_enable nls gettext` \
--mandir=/usr/share/man \
--prefix=/usr \
- --libexecdir=/usr/lib \
- --libdir=/lib \
+ --libexecdir=/usr/${mylibdir} \
+ --libdir=/${mylibdir} \
|| die
sed -i \
@@ -45,11 +48,14 @@ src_install() {
make DIST_ROOT=${D} install install-dev install-lib || die
#einstall DESTDIR=${D} install install-dev install-lib || die
- rm -f ${D}/usr/lib/libacl.so
- rm -f ${D}/lib/*a
- dosym /lib/libacl.so /usr/lib/libacl.so
- dosym /usr/lib/libacl.la /lib/libacl.la
- dosym /usr/lib/libacl.a /lib/libacl.a
+ [ -z "${CONF_LIBDIR}" ] && local mylibdir="lib"
+ [ ! -z "${CONF_LIBDIR}" ] && local mylibdir=${CONF_LIBDIR}
+
+ rm -f ${D}/usr/${mylibdir}/libacl.so
+ rm -f ${D}/${mylibdir}/*a
+ dosym /${mylibdir}/libacl.so /usr/${mylibdir}/libacl.so
+ dosym /usr/${mylibdir}/libacl.la /${mylibdir}/libacl.la
+ dosym /usr/${mylibdir}/libacl.a /${mylibdir}/libacl.a
dodir /bin
mv ${D}/usr/bin/* ${D}/bin/