summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-08-29 10:54:57 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-08-29 10:54:57 +0000
commitf378f152947870efa4c2729785e432b3992c7a84 (patch)
tree26c1695ecdcd919218eeee8bf3c75d6992f5d894 /sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
parentVersion bump, thanks to Àngel Díaz in bug #235447. (diff)
downloadhistorical-f378f152947870efa4c2729785e432b3992c7a84.tar.gz
historical-f378f152947870efa4c2729785e432b3992c7a84.tar.bz2
historical-f378f152947870efa4c2729785e432b3992c7a84.zip
Fixed linking, some cosmetics.
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64
Diffstat (limited to 'sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild')
-rw-r--r--sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild b/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
index 96384e6c2fa5..6484e230bb20 100644
--- a/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
+++ b/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild,v 1.1 2008/05/06 14:17:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/quickplot/quickplot-0.8.13-r1.ebuild,v 1.2 2008/08/29 10:54:57 bicatali Exp $
inherit eutils
@@ -14,11 +14,10 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND=">=dev-cpp/gtkmm-2.4.5
- sndfile? ( >=media-libs/libsndfile-1.0.5 )
- >=dev-libs/libsigc++-2"
+ sndfile? ( media-libs/libsndfile )"
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.15"
+ dev-util/pkgconfig"
src_unpack() {
unpack ${A}
@@ -26,23 +25,27 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-libsigc++-2.2.patch
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-linking.patch
# Some files have been moved around to more appropriate locations
- sed -i -e 's|quickplot_icon.png|/usr/share/pixmaps/quickplot.png|' \
+ sed -i \
+ -e 's|quickplot_icon.png|/usr/share/pixmaps/quickplot.png|' \
+ -e 's|href="ChangeLog"|href="../ChangeLog.gz"|' \
index.html.in
- sed -i -e 's|href="ChangeLog"|href="../ChangeLog.gz"|' index.html.in
sed -i -e 's|href="COPYING"|href="/usr/portage/licenses/GPL-2"|' \
about.html.in
}
src_compile() {
- econf `use_with sndfile libsndfile` || die "econf step failed."
+ econf $(use_with sndfile libsndfile) || die "econf step failed."
emake htmldir=/usr/share/doc/${PF}/html || die "emake step failed."
}
src_install () {
- make install DESTDIR="${D}" htmldir=/usr/share/doc/${PF}/html \
- || die "make install step failed."
+ emake \
+ DESTDIR="${D}" \
+ htmldir=/usr/share/doc/${PF}/html \
+ install || die "make install step failed."
dodoc AUTHORS ChangeLog README README.devel TODO
# Remove COPYING as it is specified in LICENCE. Move other stuff.
cd "${D}"/usr/share/doc/${PF}/html