summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-11 12:14:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-11 12:14:47 +0000
commit996e32e20b69d597aa01f1e5a7eb7b4b0773cee8 (patch)
tree6e7ad6eec22c7553b29f324146f9c376e3a7263b /sci-physics/cernlib
parentadded missing pkgconfig dep wrt bug #205494 (diff)
downloadhistorical-996e32e20b69d597aa01f1e5a7eb7b4b0773cee8.tar.gz
historical-996e32e20b69d597aa01f1e5a7eb7b4b0773cee8.tar.bz2
historical-996e32e20b69d597aa01f1e5a7eb7b4b0773cee8.zip
New series of patches from Debian, more compatible with gfortran and better tests. Much ebuild cleaning.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sci-physics/cernlib')
-rw-r--r--sci-physics/cernlib/ChangeLog11
-rw-r--r--sci-physics/cernlib/cernlib-2006-r1.ebuild110
-rw-r--r--sci-physics/cernlib/cernlib-2006.ebuild5
3 files changed, 121 insertions, 5 deletions
diff --git a/sci-physics/cernlib/ChangeLog b/sci-physics/cernlib/ChangeLog
index 7f4823a36574..92db5bca5907 100644
--- a/sci-physics/cernlib/ChangeLog
+++ b/sci-physics/cernlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/cernlib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/ChangeLog,v 1.6 2007/11/23 14:59:40 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/ChangeLog,v 1.7 2008/03/11 12:09:06 bicatali Exp $
+
+*cernlib-2006-r1 (11 Mar 2008)
+
+ 11 Mar 2008; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +cernlib-2006-r1.ebuild:
+ New series of patches from Debian, more compatible with gfortran and better
+ tests. Much ebuild cleaning.
23 Nov 2007; Samuli Suominen <drac@gentoo.org> cernlib-2006.ebuild:
amd64 stable wrt #196304
diff --git a/sci-physics/cernlib/cernlib-2006-r1.ebuild b/sci-physics/cernlib/cernlib-2006-r1.ebuild
new file mode 100644
index 000000000000..346203b40f85
--- /dev/null
+++ b/sci-physics/cernlib/cernlib-2006-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/cernlib-2006-r1.ebuild,v 1.1 2008/03/11 12:09:06 bicatali Exp $
+
+inherit eutils multilib fortran
+
+DEB_PN=cernlib
+DEB_PV=${PV}.dfsg.2
+DEB_PR=11
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="CERN program library for High Energy Physics"
+HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/cernlib"
+SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+KEYWORDS="~amd64 ~sparc ~x86"
+LICENSE="GPL-2 LGPL-2 BSD"
+
+SLOT="0"
+
+DEPEND="virtual/motif
+ virtual/lapack
+ virtual/latex-base
+ dev-lang/cfortran
+ x11-misc/imake
+ x11-misc/makedepend
+ dev-util/pkgconfig"
+
+RDEPEND="virtual/motif
+ virtual/lapack
+ dev-lang/cfortran"
+
+IUSE=""
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+FORTRAN="gfortran g77 ifc"
+
+src_unpack() {
+
+ unpack ${A}
+ epatch "${DEB_P}-${DEB_PR}".diff
+ cd "${S}"
+
+ # set some default paths
+ sed -i \
+ -e "s:/usr/local:/usr:g" \
+ -e "s:prefix)/lib:prefix)/$(get_libdir):" \
+ -e 's:$(prefix)/etc:/etc:' \
+ -e 's:$(prefix)/man:$(prefix)/share/man:' \
+ debian/add-ons/cernlib.mk || die "sed failed"
+
+ # use system blas and lapack set by gentoo framework
+ sed -i \
+ -e "s:\$DEPS -lm:$(pkg-config --libs blas):" \
+ -e "s:\$DEPS -llapack -lm:$(pkg-config --libs lapack):" \
+ -e 's:`depend $d $a blas`::' \
+ -e "s:X11R6:X11:g" \
+ debian/add-ons/bin/cernlib.in || die "sed failed"
+
+ cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
+
+ einfo "Applying Debian patches"
+ emake -j1 patch || die "debian patch failed"
+
+ # since we depend on cfortran, do not use the one from cernlib
+ rm -f src/include/cfortran/cfortran.h \
+
+ # fix an ifort problem
+ sed -i \
+ -e 's/= $(CLIBS) -nofor_main/:= $(CLIBS) -nofor_main/' \
+ src/packlib/kuip/programs/kxterm/Imakefile || die "sed ifc failed"
+
+ # respect users flags
+ sed -i \
+ -e 's/-O3/-O2/g' \
+ -e "s/-O2/${CFLAGS}/g" \
+ src/config/linux.cf || die "sed linux.cf failed"
+}
+
+src_compile() {
+ # create local LaTeX cache dir
+ mkdir -p .texmf-var
+ emake -j1 cernlib-indep cernlib-arch || die "emake libs failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test || die "emake test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"/debian
+ dodoc changelog README.* deadpool.txt NEWS copyright || die "dodoc failed"
+ newdoc add-ons/README README.add-ons || die "newdoc failed"
+}
+
+pkg_postinst() {
+ elog "Gentoo ${PN} is based on Debian similar package."
+ elog "Serious cernlib users might want to check:"
+ elog "http://people.debian.org/~kmccarty/cernlib/"
+ elog "for the changes and licensing from the original package"
+ if use amd64; then
+ elog "Please see the possible warnings for ${PN} on 64 bits:"
+ elog "${ROOT}/usr/share/doc/${PF}/README.*64*"
+ fi
+}
diff --git a/sci-physics/cernlib/cernlib-2006.ebuild b/sci-physics/cernlib/cernlib-2006.ebuild
index 5dc03bb4463f..419beaa35852 100644
--- a/sci-physics/cernlib/cernlib-2006.ebuild
+++ b/sci-physics/cernlib/cernlib-2006.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/cernlib-2006.ebuild,v 1.8 2007/11/23 14:59:40 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/cernlib-2006.ebuild,v 1.9 2008/03/11 12:09:06 bicatali Exp $
inherit eutils multilib fortran
@@ -112,7 +112,6 @@ src_compile() {
}
src_test() {
- cd "${S}"
LD_LIBRARY_PATH="${S}"/shlib make \
TEST_PACKAGES="kernlib packlib mathlib graflib" \
DEB_BUILD_OPTIONS="${FORTRANC} nostrip" \