summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2012-09-26 17:16:53 +0000
committerBenda XU <heroxbd@gentoo.org>2012-09-26 17:16:53 +0000
commitdfc426fb25e44337d6f32f6c3e6b975312bee6d2 (patch)
tree79a251ac79829b1d6970839b7cf8cb645c6adc49 /sci-mathematics
parentRemove old. (diff)
downloadhistorical-dfc426fb25e44337d6f32f6c3e6b975312bee6d2.tar.gz
historical-dfc426fb25e44337d6f32f6c3e6b975312bee6d2.tar.bz2
historical-dfc426fb25e44337d6f32f6c3e6b975312bee6d2.zip
new ebuild
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pymc/ChangeLog11
-rw-r--r--sci-mathematics/pymc/Manifest5
-rw-r--r--sci-mathematics/pymc/metadata.xml12
-rw-r--r--sci-mathematics/pymc/pymc-2.2.ebuild24
-rw-r--r--sci-mathematics/pymc/pymc-9999.ebuild24
5 files changed, 76 insertions, 0 deletions
diff --git a/sci-mathematics/pymc/ChangeLog b/sci-mathematics/pymc/ChangeLog
new file mode 100644
index 000000000000..b7c1f9b27807
--- /dev/null
+++ b/sci-mathematics/pymc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/pymc
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pymc/ChangeLog,v 1.1 2012/09/26 17:16:53 heroxbd Exp $
+
+*pymc-2.2 (27 Sep 2012)
+*pymc-9999 (27 Sep 2012)
+
+ 27 Sep 2012; Benda Xu <heroxbd@gentoo.org> +metadata.xml, +pymc-2.2.ebuild,
+ +pymc-9999.ebuild:
+ new ebuild
+
diff --git a/sci-mathematics/pymc/Manifest b/sci-mathematics/pymc/Manifest
new file mode 100644
index 000000000000..9535726b65ec
--- /dev/null
+++ b/sci-mathematics/pymc/Manifest
@@ -0,0 +1,5 @@
+DIST pymc-2.2.tar.gz 351767 RMD160 16dc4988a445bb7a2b2477c0846d979e8822854d SHA1 1deda0f15e097cae492a73f3260d57e2fd499311 SHA256 a2b5ff9c4a17dbdf93fafc3822d077956fcfa638cce6e594466f0d8523982ec1
+EBUILD pymc-2.2.ebuild 667 RMD160 74f49d949bcc78741923339389c10b1b0a984be6 SHA1 af242547d86871beac4596f897056000b634d32e SHA256 7ca4739db0982e5a260c763649b006751cc07d8e13b0c17a7a3023bb32a1f9fc
+EBUILD pymc-9999.ebuild 615 RMD160 408188e2724aa9080ac541da1efa28c29d0085e6 SHA1 ade70f152c9deb9bd2f7c8afa07748944439caf7 SHA256 e0cd1053e3d1a7e9da2817eab82a466c6d344cfba9c4c852474d73bad8ac25f4
+MISC ChangeLog 377 RMD160 8153b08291225b815cacdf7d10cadf15f37319a7 SHA1 ee6853fd1bbbceeaf34e805e5a325dcfe7e46e97 SHA256 b3c485cbe252e15d0afb56ed5726daddf9bed576bb3ea9db64c7e67493083a95
+MISC metadata.xml 409 RMD160 c33297a6a5299af13628768804b240b6358824cf SHA1 020b2edb067fe0ee5a91e78fe8135de1aae82c26 SHA256 f3717579cda034f9ff6741dc2274da937c5a3bd20f9b29678a1e98c03e77d71d
diff --git a/sci-mathematics/pymc/metadata.xml b/sci-mathematics/pymc/metadata.xml
new file mode 100644
index 000000000000..dfb8ad2183b2
--- /dev/null
+++ b/sci-mathematics/pymc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ </maintainer>
+<longdescription lang="en">
+PyMC is a python module that implements Bayesian statistical models
+and fitting algorithms, including Markov chain Monte Carlo.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/pymc/pymc-2.2.ebuild b/sci-mathematics/pymc/pymc-2.2.ebuild
new file mode 100644
index 000000000000..e06e14cda067
--- /dev/null
+++ b/sci-mathematics/pymc/pymc-2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pymc/pymc-2.2.ebuild,v 1.1 2012/09/26 17:16:53 heroxbd Exp $
+
+EAPI=4
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Markov Chain Monte Carlo sampling toolkit."
+HOMEPAGE="http://github.com/${PN}-devs/${PN} http://pypi.python.org/pypi/${PN}"
+SRC_URI="http://github.com/example/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+SLOT=0
+KEYWORDS="~amd64-linux ~x86-linux"
+LICENSE=AFL-3.0
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/pytables
+ dev-python/numpy"
+
+src_compile() {
+ distutils_src_compile --fcompiler=gnu95
+}
diff --git a/sci-mathematics/pymc/pymc-9999.ebuild b/sci-mathematics/pymc/pymc-9999.ebuild
new file mode 100644
index 000000000000..4e1b9cc28402
--- /dev/null
+++ b/sci-mathematics/pymc/pymc-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pymc/pymc-9999.ebuild,v 1.1 2012/09/26 17:16:53 heroxbd Exp $
+
+EAPI=4
+
+inherit distutils git-2
+
+EGIT_REPO_URI="http://github.com/${PN}-devs/${PN}.git"
+DESCRIPTION="Markov chain Monte Carlo for Python."
+HOMEPAGE="http://github.com/${PN}-devs/${PN} http://pypi.python.org/pypi/${PN}"
+
+SLOT=0
+KEYWORDS=""
+LICENSE=AFL-3.0
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/pytables
+ dev-python/numpy"
+
+src_compile() {
+ distutils_src_compile --fcompiler=gnu95
+}