summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-01-08 15:14:11 +0000
committerMark Wright <gienah@gentoo.org>2012-01-08 15:14:11 +0000
commit77b7891e0d4730fe891d5ba8ea305585712c10b9 (patch)
tree8eb0629fe0c0795d1d2f271a10f19a3b6cfd0112 /sci-mathematics/p9m4/p9m4-05.ebuild
parentCompress the mirrored patch, thanks to xarthisius for reviewing (diff)
downloadhistorical-77b7891e0d4730fe891d5ba8ea305585712c10b9.tar.gz
historical-77b7891e0d4730fe891d5ba8ea305585712c10b9.tar.bz2
historical-77b7891e0d4730fe891d5ba8ea305585712c10b9.zip
Thanks to xarthisius for reviewing, move S higher in file and fix missing || on cd
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics/p9m4/p9m4-05.ebuild')
-rw-r--r--sci-mathematics/p9m4/p9m4-05.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-mathematics/p9m4/p9m4-05.ebuild b/sci-mathematics/p9m4/p9m4-05.ebuild
index 2f1ef8620859..036f32619da5 100644
--- a/sci-mathematics/p9m4/p9m4-05.ebuild
+++ b/sci-mathematics/p9m4/p9m4-05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/p9m4/p9m4-05.ebuild,v 1.1 2012/01/08 14:48:52 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/p9m4/p9m4-05.ebuild,v 1.2 2012/01/08 15:14:11 gienah Exp $
EAPI="4"
PYTHON_DEPEND="2:2.5"
@@ -30,6 +30,8 @@ PATCHES=("${DISTDIR}/${MY_PN}05-64bit.patch.bz2"
"${FILESDIR}/${MY_PN}05-package.patch"
"${FILESDIR}/${MY_PN}05-python2.6.patch")
+S="${WORKDIR}/${MY_P}/"
+
pkg_setup() {
python_set_active_version 2
python_pkg_setup
@@ -68,7 +70,7 @@ src_install() {
dodir /usr/share/${PN}/Images
insinto /usr/share/${PN}/Images
cd "${S}/Images" \
- die "Could not cd to Images"
+ || die "Could not cd to Images"
doins *.gif *.ico
if use examples; then
dodir /usr/share/${PN}/Samples
@@ -106,5 +108,3 @@ src_install() {
pkg_postinst() {
distutils_pkg_postinst
}
-
-S="${WORKDIR}/${MY_P}/"