summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-09 17:57:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-09 17:57:46 +0000
commite77e797ab016bcbf88025730b5bda290a00a183a (patch)
tree0625d98319a9efaaeae1d9167bc9a33d53ffe0ce /sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild
parentVersion bump. Install standalone.py as viewvc-standalone-server (bug #349881). (diff)
downloadhistorical-e77e797ab016bcbf88025730b5bda290a00a183a.tar.gz
historical-e77e797ab016bcbf88025730b5bda290a00a183a.tar.bz2
historical-e77e797ab016bcbf88025730b5bda290a00a183a.zip
Version bump. Initial import to the main tree
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild')
-rw-r--r--sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild b/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild
new file mode 100644
index 000000000000..962fdc03ba58
--- /dev/null
+++ b/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild,v 1.1 2011/03/09 17:57:46 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DEB_PR=2
+DESCRIPTION="Graphical output functions for Matlab and Octave"
+HOMEPAGE="http://www.epstk.de/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.debian.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="sci-mathematics/octave
+ app-text/ghostscript-gpl"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ local p
+ cd eps*
+ for p in $(cat "${WORKDIR}"/debian/patches/series); do
+ epatch "${WORKDIR}"/debian/patches/${p}
+ done
+}
+
+src_install () {
+ insinto /usr/share/octave/site/m/${PN}
+ doins eps*/m/* || die
+ use doc && dohtml -r eps*/doc/*
+ insinto /etc
+ doins debian/epstk.conf || die
+ dodoc debian/README.Debian debian/changelog
+}