summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2012-05-11 16:11:40 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2012-05-11 16:11:40 +0000
commit481f0cda5bf002e6d17039149dd7a19db1f29f42 (patch)
treee30b6b67dbfdff7ec90ee3e06662abec51fd07db /sci-mathematics/mlpy
parentVersion bump. (diff)
downloadhistorical-481f0cda5bf002e6d17039149dd7a19db1f29f42.tar.gz
historical-481f0cda5bf002e6d17039149dd7a19db1f29f42.tar.bz2
historical-481f0cda5bf002e6d17039149dd7a19db1f29f42.zip
New package: Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling.
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics/mlpy')
-rw-r--r--sci-mathematics/mlpy/ChangeLog11
-rw-r--r--sci-mathematics/mlpy/Manifest4
-rw-r--r--sci-mathematics/mlpy/metadata.xml8
-rw-r--r--sci-mathematics/mlpy/mlpy-3.5.0.ebuild31
4 files changed, 54 insertions, 0 deletions
diff --git a/sci-mathematics/mlpy/ChangeLog b/sci-mathematics/mlpy/ChangeLog
new file mode 100644
index 000000000000..490b111515b7
--- /dev/null
+++ b/sci-mathematics/mlpy/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/mlpy
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/ChangeLog,v 1.1 2012/05/11 16:11:40 dberkholz Exp $
+
+*mlpy-3.5.0 (11 May 2012)
+
+ 11 May 2012; Donnie Berkholz <dberkholz@gentoo.org>; +mlpy-3.5.0.ebuild,
+ +metadata.xml:
+ New package: Machine Learning PYthon (mlpy) is a high-performance Python
+ library for predictive modeling.
+
diff --git a/sci-mathematics/mlpy/Manifest b/sci-mathematics/mlpy/Manifest
new file mode 100644
index 000000000000..a5a01fb3343d
--- /dev/null
+++ b/sci-mathematics/mlpy/Manifest
@@ -0,0 +1,4 @@
+DIST mlpy-3.5.0.tar.gz 1961206 RMD160 9dfb6387214859993d66db9108d07340aacb35c6 SHA1 32f986f7f0f7cce5c773d2909d34705eab39df16 SHA256 344fa75fbf9f76af72f6a346d5309613defc4d244bac13c218e509a51d68bf6a
+EBUILD mlpy-3.5.0.ebuild 806 RMD160 97a0255d3fa3e90ea335ecca0428e44125de426e SHA1 2e91def08548ddd78a4c55dc4a6a1f197d046f8a SHA256 35f7b12ab5ee06d8204676a4a418775adf5cbdf52acf25c88f16498c5f961185
+MISC ChangeLog 446 RMD160 4f11a8f801affc834794867892e2bd84077183eb SHA1 1338dafa45658a1ee1f5e60fbe2d3ba26862a185 SHA256 ba8ba7d573aabb647dd646ee03c53209ea2cd3e34fc88603c80f4129c0515551
+MISC metadata.xml 237 RMD160 03229478f7036946480352eea660d1e3fbe17c57 SHA1 a6c8ec7a69ee50f445c477e9da7158ec86c9f983 SHA256 f3c24a77daf83f9fcc5a23a96a5c6942f8f4e91538e014a0976141e6b0c0bbee
diff --git a/sci-mathematics/mlpy/metadata.xml b/sci-mathematics/mlpy/metadata.xml
new file mode 100644
index 000000000000..f48d50709994
--- /dev/null
+++ b/sci-mathematics/mlpy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dberkholz@gentoo.org</email>
+ <name>Donnie Berkholz</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-mathematics/mlpy/mlpy-3.5.0.ebuild b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
new file mode 100644
index 000000000000..79837aa931d9
--- /dev/null
+++ b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/mlpy-3.5.0.ebuild,v 1.1 2012/05/11 16:11:40 dberkholz Exp $
+
+EAPI=4
+
+inherit distutils
+
+DESCRIPTION="Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling"
+HOMEPAGE="https://mlpy.fbk.eu/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+RDEPEND=">=sci-libs/gsl-1.11
+ >=dev-python/numpy-1.3
+ >=sci-libs/scipy-0.7
+ >=dev-lang/python-2.6"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ pushd docs 2>/dev/null || die
+ emake html || die
+ dohtml -r build/html/*
+ popd 2>/dev/null || die
+ fi
+}