summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 19:24:10 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 19:24:10 +0000
commit4edb477cdbbfa05b1bb93e3c8fb1440e4bef8bd9 (patch)
tree85b84f50e74271dd5c0af72ff6cfc18ad0c8a1bb /sci-libs/udunits/udunits-1.12.1.ebuild
parentChange encoding to UTF-8 for GLEP 31 compliance (diff)
downloadhistorical-4edb477cdbbfa05b1bb93e3c8fb1440e4bef8bd9.tar.gz
historical-4edb477cdbbfa05b1bb93e3c8fb1440e4bef8bd9.tar.bz2
historical-4edb477cdbbfa05b1bb93e3c8fb1440e4bef8bd9.zip
Moved from app-sci/udunits to sci-libs/udunits.
Diffstat (limited to 'sci-libs/udunits/udunits-1.12.1.ebuild')
-rw-r--r--sci-libs/udunits/udunits-1.12.1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/sci-libs/udunits/udunits-1.12.1.ebuild b/sci-libs/udunits/udunits-1.12.1.ebuild
new file mode 100644
index 000000000000..665782289c34
--- /dev/null
+++ b/sci-libs/udunits/udunits-1.12.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/udunits/udunits-1.12.1.ebuild,v 1.1 2004/12/28 19:24:10 ribosome Exp $
+
+inherit eutils flag-o-matic
+
+IUSE=""
+
+S=${WORKDIR}/${P}/src
+SP=${WORKDIR}/${P}/src/perl
+DESCRIPTION="The UCAR/Unidata Units library"
+HOMEPAGE="http://www.unidata.ucar.edu/packages/udunits/"
+SRC_URI="ftp://unidata.ucar.edu/pub/udunits/udunits-${PV}.tar.Z"
+
+SLOT="0"
+LICENSE="UCAR-Unidata"
+KEYWORDS="x86 ~amd64 ~ppc ~sparc alpha ~mips ~hppa"
+
+DEPEND="dev-lang/perl
+ sys-apps/sed"
+
+RDEPEND="dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/udunits_customize.patch || die "epatch failed"
+}
+
+src_compile() {
+ export CPPFLAGS="-Df2cFortran -D_POSIX_SOURCE"
+ append-flags -fPIC
+ econf || die "econf failed"
+
+ cd lib
+ emake || die
+ cd ..
+
+ cd perl
+ perl Makefile.PL PREFIX=${D}/usr
+ cd ..
+
+ emake || die
+ emake test || die
+}
+
+src_install() {
+ sed "s?/usr?${D}/usr?" Makefile > Makefile.install
+ emake -f Makefile.install install
+
+ dodir /etc /usr/share/man/man3 /usr/share/man/man3f
+
+ insinto /etc
+ insopts -m 644
+ doins lib/udunits.dat
+
+ insinto /usr/share/man/man3
+ doins lib/udunits.3
+ insinto /usr/share/man/man3f
+ doins lib/udunits.3f
+
+ cd perl
+ make PREFIX=${D}/usr install INSTALLSITEMAN1DIR=${D}/usr/share/man/man1
+ cd ..
+
+ find ${D} -type f -a \( -name perllocal.pod -o -name .packlist \
+ -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
+ find ${D} -type d -depth -exec rmdir {} 2>/dev/null ';'
+
+ chmod -R u+w ${D}/*
+
+ dodoc COPYRIGHT README RELEASE_NOTES VERSION CUSTOMIZE INSTALL
+}
+
+pkg_postinst() {
+ ewarn "This package requires a Fortran compiler for maximum utility."
+ ewarn "For now, make sure you have at least g77 for the f77 interface."
+ ewarn "The internal configure should detect many f77 compilers, however,"
+ ewarn "if you have the PG compiler you will need to change the above"
+ ewarn "preprocessor macro to something like -Dpgifortran."
+}