summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-12 22:53:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-12 22:53:04 +0000
commitb0069ab7eb2610c08b5a9e8003e0265442fbaca2 (patch)
treec3d7c6dc067a430813053bacf0f28842548071d6 /sci-libs/qd/qd-2.3.12.ebuild
parentVersion bump; remove old (diff)
downloadhistorical-b0069ab7eb2610c08b5a9e8003e0265442fbaca2.tar.gz
historical-b0069ab7eb2610c08b5a9e8003e0265442fbaca2.tar.bz2
historical-b0069ab7eb2610c08b5a9e8003e0265442fbaca2.zip
Version bump. Build shared libraries and fix a bunch of autotools errors
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/qd/qd-2.3.12.ebuild')
-rw-r--r--sci-libs/qd/qd-2.3.12.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/qd/qd-2.3.12.ebuild b/sci-libs/qd/qd-2.3.12.ebuild
new file mode 100644
index 000000000000..5d669e3bc015
--- /dev/null
+++ b/sci-libs/qd/qd-2.3.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.12.ebuild,v 1.1 2012/01/12 22:53:04 bicatali Exp $
+
+EAPI=4
+
+inherit autotools eutils fortran-2
+
+DESCRIPTION="Quad-double and double-double float arithmetics"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fortran static-libs"
+
+DEPEND="fortran? ( virtual/fortran )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable fortran enable_fortran)
+}
+
+src_install() {
+ default
+ use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
+ dosym qd_real.h /usr/include/qd/qd.h
+ dosym dd_real.h /usr/include/qd/dd.h
+}