summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-24 11:02:06 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-24 11:02:06 +0000
commit96e101dfb71e76c31e6fba6f88d7795275ea9e91 (patch)
tree134beaf40ba4d3b16ed906a2e01fa3db9a257116 /sci-libs/fftw/files
parentRemove test from IUSE, bug 232497. (diff)
downloadhistorical-96e101dfb71e76c31e6fba6f88d7795275ea9e91.tar.gz
historical-96e101dfb71e76c31e6fba6f88d7795275ea9e91.tar.bz2
historical-96e101dfb71e76c31e6fba6f88d7795275ea9e91.zip
Version bump. Thanks to Adam Pi#tyszek, closing bug #247561
Package-Manager: portage-2.2_rc15/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'sci-libs/fftw/files')
-rw-r--r--sci-libs/fftw/files/fftw-3.2-as-needed.patch36
-rw-r--r--sci-libs/fftw/files/fftw-3.2-cppflags.patch11
-rw-r--r--sci-libs/fftw/files/fftw-3.2-openmp.patch28
3 files changed, 75 insertions, 0 deletions
diff --git a/sci-libs/fftw/files/fftw-3.2-as-needed.patch b/sci-libs/fftw/files/fftw-3.2-as-needed.patch
new file mode 100644
index 000000000000..c991b20f2396
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-3.2-as-needed.patch
@@ -0,0 +1,36 @@
+--- Makefile.am.orig 2008-11-19 10:05:22.000000000 +0100
++++ Makefile.am 2008-11-19 10:06:56.000000000 +0100
+@@ -37,6 +37,13 @@
+ if SMP
+ if COMBINED_THREADS
+ COMBINED_THREADLIBS=threads/libfftw3@PREC_SUFFIX@_threads.la
++else
++lib_LTLIBRARIES += libfftw3@PREC_SUFFIX@_threads.la
++libfftw3@PREC_SUFFIX@_threads_la_SOURCES =
++libfftw3@PREC_SUFFIX@_threads_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
++libfftw3@PREC_SUFFIX@_threads_la_LIBADD = \
++ libfftw3@PREC_SUFFIX@.la \
++ threads/libfftw3@PREC_SUFFIX@_threads.la
+ endif
+ endif
+
+--- threads/Makefile.am.orig 2008-11-19 10:03:43.000000000 +0100
++++ threads/Makefile.am 2008-11-19 10:05:13.000000000 +0100
+@@ -2,11 +2,7 @@
+ -I$(top_srcdir)/rdft -I$(top_srcdir)/api
+
+ if SMP
+-if COMBINED_THREADS
+ noinst_LTLIBRARIES = libfftw3@PREC_SUFFIX@_threads.la
+-else
+-lib_LTLIBRARIES = libfftw3@PREC_SUFFIX@_threads.la
+-endif
+ endif
+
+ # pkgincludedir = $(includedir)/fftw3@PREC_SUFFIX@
+@@ -16,4 +12,5 @@
+ openmp.c threads.h dft-vrank-geq1.c ct.c rdft-vrank-geq1.c hc2hc.c \
+ vrank-geq1-rdft2.c f77api.c f77funcs.h
+
++libfftw3@PREC_SUFFIX@_threads_la_LIBADD = $(THREADLIBS)
+ libfftw3@PREC_SUFFIX@_threads_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
diff --git a/sci-libs/fftw/files/fftw-3.2-cppflags.patch b/sci-libs/fftw/files/fftw-3.2-cppflags.patch
new file mode 100644
index 000000000000..4d9a1b01c028
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-3.2-cppflags.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-11-19 09:57:26.000000000 +0100
++++ configure.ac 2008-11-19 09:59:08.000000000 +0100
+@@ -264,6 +264,8 @@
+ fi
+ fi
+ AC_SUBST(SIMD_CFLAGS)
++# pass simd flags to preprocessor/compiler for proper intrinsics detection.
++CPPFLAGS="$CPPFLAGS $SIMD_CFLAGS"
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
diff --git a/sci-libs/fftw/files/fftw-3.2-openmp.patch b/sci-libs/fftw/files/fftw-3.2-openmp.patch
new file mode 100644
index 000000000000..254b9a05a28b
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-3.2-openmp.patch
@@ -0,0 +1,28 @@
+--- configure.ac.orig 2008-11-19 09:57:26.000000000 +0100
++++ configure.ac 2008-11-19 09:59:08.000000000 +0100
+@@ -435,10 +437,10 @@
+ AC_ARG_WITH(combined-threads, [AC_HELP_STRING([--with-combined-threads],[combine threads into main libfftw3])], with_combined_threads=$withval, with_combined_threads=no)
+
+ if test "$enable_openmp"x != nox; then
+- AX_OPENMP([THREADLIBS=" "
++ AX_OPENMP([THREADLIBS="$OPENMP_LIBS"
+ AC_DEFINE(USING_OPENMP_THREADS, 1, [Define if we have and are using OpenMP multithreading directives])
+ CFLAGS="$CFLAGS $OPENMP_CFLAGS"],
+- [AC_MSG_ERROR([don't know how to enable OpenMP])])
++ [AC_MSG_WARN([don't know how to enable OpenMP, reverting to POSIX threads])])
+ fi
+
+ dnl Check for threads library...
+--- m4/ax_openmp.m4.orig 2008-07-10 11:33:17.361562576 +0100
++++ m4/ax_openmp.m4 2008-07-10 12:05:14.280159723 +0100
+@@ -59,6 +59,10 @@
+ else
+ if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" != "xnone"; then
+ OPENMP_[]_AC_LANG_PREFIX[]FLAGS=$ax_cv_[]_AC_LANG_ABBREV[]_openmp
++ OPENMP_LIBS=" "
++ if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" = "x-fopenmp"; then
++ OPENMP_LIBS="-lgomp"
++ fi
+ fi
+ m4_default([$1], [AC_DEFINE(HAVE_OPENMP,1,[Define if OpenMP is enabled])])
+ fi