summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-28 18:58:03 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-28 18:58:03 +0000
commit3690fd54f6be4f3daa6df4916e2636b4220bdee2 (patch)
treea00ef7e4108a01545e1bc28464b1a28507cbd6b2 /sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
parentNew ebuild for osm-gps-map. Made by Jorge Manuel B. S. Vicetto aka jmbsvicett... (diff)
downloadhistorical-3690fd54f6be4f3daa6df4916e2636b4220bdee2.tar.gz
historical-3690fd54f6be4f3daa6df4916e2636b4220bdee2.tar.bz2
historical-3690fd54f6be4f3daa6df4916e2636b4220bdee2.zip
New ebuild for osm-gps-map. Made by Jorge Manuel B. S. Vicetto aka jmbsvicetto, corrected by Aaron Bauman aka B-Man. Partially fixes bug #373809 which still awaits Python bindings.
Package-Manager: portage-2.1.11.59/cvs/Linux x86_64 Manifest-Sign-Key: 0x6D34E57D
Diffstat (limited to 'sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild')
-rw-r--r--sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild b/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
new file mode 100644
index 000000000000..6cb769cfd9f6
--- /dev/null
+++ b/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild,v 1.1 2013/03/28 18:57:59 tomwij Exp $
+
+EAPI="5"
+
+inherit autotools gnome2
+
+DESCRIPTION="A gtk+ viewer for OpenStreetMap files."
+HOMEPAGE="http://nzjrs.github.com/${PN}/"
+SRC_URI="http://www.johnstowers.co.nz/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="introspection python"
+
+DEPEND="
+ >=dev-libs/glib-2.16.0
+ gnome-base/gnome-common
+ >=net-libs/libsoup-2.4.0
+ >=x11-libs/cairo-1.6.0
+ >=x11-libs/gtk+-2.14.0
+ introspection? ( dev-libs/gobject-introspection )
+"
+RDEPEND="${DEPEND}"
+
+G2CONF="
+ $(use_enable introspection)
+ --docdir=/usr/share/doc/${PN}
+ --disable-dependency-tracking
+ --enable-fast-install
+ --disable-static
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-docs-location.patch"
+# epatch "${FILESDIR}/${P}-disable-compiler-warnings.patch"
+ eautoreconf
+
+ gnome2_src_prepare
+}