summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-22 11:28:39 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-22 11:28:39 +0000
commitce672dd063ad551e038f8ea105f05739f1cc9ee7 (patch)
tree64f620e481eec2ff5f02e56fd1c33151029e5917 /sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
parentppc64 stable wrt #369897 (diff)
downloadhistorical-ce672dd063ad551e038f8ea105f05739f1cc9ee7.tar.gz
historical-ce672dd063ad551e038f8ea105f05739f1cc9ee7.tar.bz2
historical-ce672dd063ad551e038f8ea105f05739f1cc9ee7.zip
Stabilise revison-bumped gdal-grass that works with grass-6.4. Punt older. This actualy makes stable compile again.
Package-Manager: portage-2.2.0_alpha46/cvs/Linux x86_64
Diffstat (limited to 'sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild')
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild b/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
index 78c8150e3f12..01980fb9d6af 100644
--- a/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
+++ b/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild,v 1.1 2010/06/13 09:20:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild,v 1.2 2011/07/22 11:28:38 scarabeus Exp $
+
+EAPI=4
-EAPI=2
inherit eutils
DESCRIPTION="GDAL plugin to access GRASS data"
@@ -11,12 +12,14 @@ SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="sci-libs/gdal
- >=sci-geosciences/grass-6.4.0_rc6"
+RDEPEND="
+ sci-libs/gdal
+ >=sci-geosciences/grass-6.4.0_rc6
+"
DEPEND="${RDEPEND}"
src_prepare() {
@@ -24,7 +27,9 @@ src_prepare() {
}
src_configure() {
- econf --with-grass=$(pkg-config grass --variable grassdir) --with-gdal
+ econf \
+ --with-grass=$(pkg-config grass --variable grassdir) \
+ --with-gdal
}
src_install() {
@@ -32,5 +37,5 @@ src_install() {
emake DESTDIR="${D}" \
GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
- install || die "emake install failure"
+ install
}