summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-02-05 21:17:41 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-02-05 21:17:41 +0000
commit4cdce3ff9fee9de17ba886fd1f63994332da547d (patch)
treeb8566fdd44ea2d5bf33171680be02bbf2d0b32d2 /sci-chemistry
parentUpdate changelog to remove warnings on http://gentoo.tamperd.net/stable/. (diff)
downloadhistorical-4cdce3ff9fee9de17ba886fd1f63994332da547d.tar.gz
historical-4cdce3ff9fee9de17ba886fd1f63994332da547d.tar.bz2
historical-4cdce3ff9fee9de17ba886fd1f63994332da547d.zip
(#79047) New version, supports gromacs file format and some other stuff.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molden/ChangeLog9
-rw-r--r--sci-chemistry/molden/Manifest12
-rw-r--r--sci-chemistry/molden/files/digest-molden-4.31
-rw-r--r--sci-chemistry/molden/molden-4.3.ebuild70
4 files changed, 85 insertions, 7 deletions
diff --git a/sci-chemistry/molden/ChangeLog b/sci-chemistry/molden/ChangeLog
index eb71480617b9..3792ab78f457 100644
--- a/sci-chemistry/molden/ChangeLog
+++ b/sci-chemistry/molden/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/molden
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/ChangeLog,v 1.3 2004/12/29 21:29:50 ciaranm Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/ChangeLog,v 1.4 2005/02/05 21:17:41 spyderous Exp $
+
+*molden-4.3 (05 Feb 2005)
+
+ 05 Feb 2005; Donnie Berkholz <spyderous@gentoo.org>; +molden-4.3.ebuild:
+ (#79047) New version, supports gromacs file format and some other stuff.
29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/sci-chemistry/molden/Manifest b/sci-chemistry/molden/Manifest
index 106e2d40dbc2..e0c3c7adf15d 100644
--- a/sci-chemistry/molden/Manifest
+++ b/sci-chemistry/molden/Manifest
@@ -1,9 +1,11 @@
-MD5 5de5f8e01d28319884c78fea9e29c263 molden-4.1.ebuild 1843
-MD5 f34a10937a29a013e24211a23616d791 ChangeLog 2777
-MD5 e5559ddd4c17bae52a29f099846dcb99 molden-4.0.ebuild 1830
-MD5 f55f29b89820645b876d62558b67c542 molden-3.9.ebuild 1750
+MD5 31597d65d0e98ef6db4d6d11c5b1bfc4 ChangeLog 2957
MD5 af1bfbb0777267a03e889b08173f2757 metadata.xml 248
+MD5 f55f29b89820645b876d62558b67c542 molden-3.9.ebuild 1750
+MD5 e5559ddd4c17bae52a29f099846dcb99 molden-4.0.ebuild 1830
+MD5 5de5f8e01d28319884c78fea9e29c263 molden-4.1.ebuild 1843
+MD5 882f10346974b47359ad992172c1ab85 molden-4.3.ebuild 1845
+MD5 d06154ddfaab5d99bd967f2ca2b53652 files/digest-molden-3.9 61
MD5 bbe8bcdbccb478cc81982616a13d5e5f files/digest-molden-4.0 61
MD5 05e3e6790a565d9173b003c02a09c902 files/digest-molden-4.1 61
MD5 a7a0b16c6ab47f386e92f719c1eb6966 files/molden-3.9-fixMakefile.patch 1232
-MD5 d06154ddfaab5d99bd967f2ca2b53652 files/digest-molden-3.9 61
+MD5 1c17f79846de520b4d220d2d28d79521 files/digest-molden-4.3 61
diff --git a/sci-chemistry/molden/files/digest-molden-4.3 b/sci-chemistry/molden/files/digest-molden-4.3
new file mode 100644
index 000000000000..227b171d48c7
--- /dev/null
+++ b/sci-chemistry/molden/files/digest-molden-4.3
@@ -0,0 +1 @@
+MD5 12542915523bd24ea2177d07508685ca molden4.3.tar.Z 3334599
diff --git a/sci-chemistry/molden/molden-4.3.ebuild b/sci-chemistry/molden/molden-4.3.ebuild
new file mode 100644
index 000000000000..9434e3e6deae
--- /dev/null
+++ b/sci-chemistry/molden/molden-4.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molden/molden-4.3.ebuild,v 1.1 2005/02/05 21:17:41 spyderous Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${PN}${PV}"
+DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac."
+HOMEPAGE="http://www.cmbi.kun.nl/~schaft/molden/molden.html"
+SRC_URI="ftp://ftp.cmbi.kun.nl/pub/molgraph/${PN}/${MY_P}.tar.Z"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="opengl"
+
+DEPEND="virtual/libc
+ virtual/x11"
+RDEPEND="virtual/x11
+ opengl? ( media-libs/glut )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ # Set fortran compiler, since gcc-config doesn't
+ [ -z ${FC} ] && FC="g77"
+
+ # Check for fortran compiler
+ if [ ! "`which ${FC} 2> /dev/null`" ]; then
+ eerror "Fortran compiler not found."
+ eerror "Please recompile sys-devel/gcc with f77 in USE flags."
+ die
+ fi
+
+ unpack ${A}
+ cd ${S}
+
+ # No need to add a new identical patch
+ # assuming people don't stupidly remove 3.9 patch with 3.9
+ epatch ${FILESDIR}/${PN}-3.9-fixMakefile.patch
+}
+
+src_compile() {
+ # Use -mieee on alpha, according to the Makefile
+ use alpha && append-flags -mieee
+
+ # Honor CC, CFLAGS, FC, and FFLAGS from environment;
+ # unfortunately a bash bug prevents us from doing typeset and
+ # assignment on the same line.
+ typeset -a args
+ args=( CC="$(tc-getCC) ${CFLAGS}" \
+ ${FC:+FC="${FC}" LDR="${FC}"} \
+ ${FFLAGS:+FFLAGS="${FFLAGS}"} )
+
+ einfo "Building Molden..."
+ emake "${args[@]}" || die "molden emake failed"
+ if use opengl ; then
+ einfo "Building Molden OpenGL helper..."
+ emake "${args[@]}" moldenogl || die "moldenogl emake failed"
+ fi
+}
+
+src_install() {
+ dobin molden
+ use opengl && dobin moldenogl
+ dodoc HISTORY README REGISTER
+ cd doc
+ uncompress *
+ dodoc *
+}