summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-30 09:14:16 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-30 09:14:16 +0000
commiteee35dafa99da41aa6426a0b06b1913a3fee5792 (patch)
tree7da26dbeca6d4d35368b4dd1e560311b9d9159c7 /sci-chemistry/xdsgui/xdsgui-0_p130530.ebuild
parentsci-chemistry/xdsgui: New addition (diff)
downloadhistorical-eee35dafa99da41aa6426a0b06b1913a3fee5792.tar.gz
historical-eee35dafa99da41aa6426a0b06b1913a3fee5792.tar.bz2
historical-eee35dafa99da41aa6426a0b06b1913a3fee5792.zip
sci-chemistry/xdsgui: New addition
Package-Manager: portage-2.2.0_alpha177/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'sci-chemistry/xdsgui/xdsgui-0_p130530.ebuild')
-rw-r--r--sci-chemistry/xdsgui/xdsgui-0_p130530.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-chemistry/xdsgui/xdsgui-0_p130530.ebuild b/sci-chemistry/xdsgui/xdsgui-0_p130530.ebuild
new file mode 100644
index 000000000000..0475db94ee32
--- /dev/null
+++ b/sci-chemistry/xdsgui/xdsgui-0_p130530.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdsgui/xdsgui-0_p130530.ebuild,v 1.1 2013/05/30 09:14:15 jlec Exp $
+
+EAPI=5
+
+DESCRIPTION="GUI for XDS that is supposed to help both novice and experienced users"
+HOMEPAGE="http://strucbio.biologie.uni-konstanz.de/xdswiki/index.php/XdsGUI"
+SRC_URI="
+ amd64? ( ftp://turn5.biologie.uni-konstanz.de/pub/xdsGUI.rhel6.64 -> ${P}.64 )
+ x86? ( ftp://turn5.biologie.uni-konstanz.de/pub/xdsGUI.rhel6.32 -> ${P}.32 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-util/xxdiff
+ sci-chemistry/xds-bin
+ sci-visualization/xds-viewer"
+DEPEND=""
+
+src_unpack() {
+ if use amd64; then
+ cp -rf "${DISTDIR}"/${P}.64 ${PN} || die
+ elif use x86; then
+ cp -rf "${DISTDIR}"/${P}.32 ${PN} || die
+ fi
+}
+
+src_install() {
+ exeinto /opt/bin
+ dobin ${PN}
+}