summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-12-02 19:44:14 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-12-02 19:44:14 +0000
commita13ff1b3c616b08b120341d3f6c033ceece1cd43 (patch)
tree96bfaa9b66dba3164c86557c556d3955355de82d /sci-chemistry/viewmol/viewmol-2.4.1.ebuild
parentBumps for fixing wrong rotation and handling filenames with spaces in epstopd... (diff)
downloadhistorical-a13ff1b3c616b08b120341d3f6c033ceece1cd43.tar.gz
historical-a13ff1b3c616b08b120341d3f6c033ceece1cd43.tar.bz2
historical-a13ff1b3c616b08b120341d3f6c033ceece1cd43.zip
New GUI front-end for computational chemistry.
Package-Manager: portage-2.0.53
Diffstat (limited to 'sci-chemistry/viewmol/viewmol-2.4.1.ebuild')
-rw-r--r--sci-chemistry/viewmol/viewmol-2.4.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-chemistry/viewmol/viewmol-2.4.1.ebuild b/sci-chemistry/viewmol/viewmol-2.4.1.ebuild
new file mode 100644
index 000000000000..1435448430e6
--- /dev/null
+++ b/sci-chemistry/viewmol/viewmol-2.4.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/viewmol/viewmol-2.4.1.ebuild,v 1.1 2005/12/02 19:44:14 spyderous Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Open-source graphical front end for computational chemistry programs"
+HOMEPAGE="http://viewmol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewmol/${P}.src.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="media-libs/tiff
+ virtual/opengl
+ virtual/motif
+ media-libs/libpng
+ >=dev-lang/python-2.2
+ || ( (
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw
+ )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/inputproto
+ x11-proto/xproto
+ )
+ virtual/x11
+ )"
+
+S="${WORKDIR}/${P}/source"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-remove-icc-check.patch
+ epatch ${FILESDIR}/${PV}-look-for-python-in-right-place.patch
+ epatch ${FILESDIR}/${PV}-use-root-for-app-defaults.patch
+ epatch ${FILESDIR}/${PV}-change-default-path-to-usr.patch
+}
+
+src_compile() {
+ ./getmachine
+ emake -j1 \
+ COMPILER=$(tc-getCC) \
+ OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ ./install ${D}/usr || die
+}