summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 06:43:37 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 06:43:37 +0000
commit419a4159bd2babfa24b48562b0c83f07dadab3a7 (patch)
treedf6d924540040509f49d8c975446c7f9ba71e526 /sci-chemistry/mopac7/mopac7-1.13.ebuild
parentFix minor syntax errors. (diff)
downloadhistorical-419a4159bd2babfa24b48562b0c83f07dadab3a7.tar.gz
historical-419a4159bd2babfa24b48562b0c83f07dadab3a7.tar.bz2
historical-419a4159bd2babfa24b48562b0c83f07dadab3a7.zip
Bump. Pull in newer libf2c so configure doesn't fail.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64
Diffstat (limited to 'sci-chemistry/mopac7/mopac7-1.13.ebuild')
-rw-r--r--sci-chemistry/mopac7/mopac7-1.13.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-chemistry/mopac7/mopac7-1.13.ebuild b/sci-chemistry/mopac7/mopac7-1.13.ebuild
new file mode 100644
index 000000000000..e84f05521093
--- /dev/null
+++ b/sci-chemistry/mopac7/mopac7-1.13.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.13.ebuild,v 1.1 2008/07/08 06:43:37 dberkholz Exp $
+
+WANT_AUTOMAKE="1.8"
+WANT_AUTOCONF="latest"
+
+inherit autotools
+
+DESCRIPTION="Autotooled, updated version of a powerful, fast semi-empirical package"
+HOMEPAGE="http://sourceforge.net/projects/mopac7/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=">=dev-libs/libf2c-20070912"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Install the executable
+ sed -i \
+ -e "s:noinst_PROGRAMS = mopac7:bin_PROGRAMS = mopac7:g" \
+ src/Makefile.am \
+ || die "sed failed: install mopac7"
+ # Install the script to run the executable
+ sed -i \
+ -e "s:EXTRA_DIST = run_mopac7:if HAVE_F2C\nbin_SCRIPTS = run_mopac7\nendif:g" \
+ Makefile.am \
+ || die "sed failed: install run_mopac7"
+
+ # Fix parallel build by adding internal dependency on libmopac7.la from
+ # executable
+ sed -i \
+ -e "s:mopac7_LDFLAGS = -lmopac7 -lf2c -lm:mopac7_LDFLAGS = -lf2c -lm:g" \
+ -e "s:\(mopac7_LDFLAGS.*\):\1\nmopac7_LDADD = libmopac7.la:g" \
+ src/Makefile.am \
+ || die "sed failed: fix dependencies"
+
+ eautoreconf
+}
+
+src_install() {
+ # A correct fix would have a run_mopac7.in with @bindir@ that gets
+ # replaced by configure, and run_mopac7 added to AC_OUTPUT in configure.ac
+ sed -i "s:./src/mopac7:mopac7:g" run_mopac7
+
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog
+}