summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-23 08:00:27 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-23 08:00:27 +0000
commit551c170e58a779d673aa34ed7b5403d899e0c8cb (patch)
tree9ffbc824043e3ebaff480150fd899c734b0cbaf3 /sci-chemistry/cluster
parentversion bump and remove previous (unfetchable) version (diff)
downloadhistorical-551c170e58a779d673aa34ed7b5403d899e0c8cb.tar.gz
historical-551c170e58a779d673aa34ed7b5403d899e0c8cb.tar.bz2
historical-551c170e58a779d673aa34ed7b5403d899e0c8cb.zip
sci-chemistry/cluster: Move to EAPI=4, respect CFLAGS
Package-Manager: portage-2.2.0_alpha107/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/cluster')
-rw-r--r--sci-chemistry/cluster/ChangeLog8
-rw-r--r--sci-chemistry/cluster/cluster-1.3.081231.ebuild17
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-ldflags.patch18
-rw-r--r--sci-chemistry/cluster/metadata.xml10
4 files changed, 29 insertions, 24 deletions
diff --git a/sci-chemistry/cluster/ChangeLog b/sci-chemistry/cluster/ChangeLog
index f0708558c099..2a01a7655fab 100644
--- a/sci-chemistry/cluster/ChangeLog
+++ b/sci-chemistry/cluster/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/cluster
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cluster/ChangeLog,v 1.1 2010/07/18 08:27:49 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cluster/ChangeLog,v 1.2 2012/05/23 08:00:27 jlec Exp $
+
+ 23 May 2012; Justin Lecher <jlec@gentoo.org> files/1.3.081231-ldflags.patch,
+ cluster-1.3.081231.ebuild, metadata.xml:
+ Move to EAPI=4, respect CFLAGS
*cluster-1.3.081231 (18 Jul 2010)
diff --git a/sci-chemistry/cluster/cluster-1.3.081231.ebuild b/sci-chemistry/cluster/cluster-1.3.081231.ebuild
index 4d3d59c17599..a294d7f5a720 100644
--- a/sci-chemistry/cluster/cluster-1.3.081231.ebuild
+++ b/sci-chemistry/cluster/cluster-1.3.081231.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cluster/cluster-1.3.081231.ebuild,v 1.1 2010/07/18 08:27:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cluster/cluster-1.3.081231.ebuild,v 1.2 2012/05/23 08:00:27 jlec Exp $
-EAPI="3"
+EAPI=4
inherit eutils toolchain-funcs
@@ -24,15 +24,10 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PV}-ldflags.patch \
"${FILESDIR}"/${PV}-includes.patch
-}
-
-src_compile() {
- emake \
- CXX="$(tc-getCXX)" \
- || die
+ tc-export CXX
}
src_install() {
- dobin ${PN} || die
- dodoc README.cluster || die
+ dobin ${PN}
+ dodoc README.cluster
}
diff --git a/sci-chemistry/cluster/files/1.3.081231-ldflags.patch b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
index d407e0bc8b8f..1b99f6d662f2 100644
--- a/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
+++ b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
@@ -1,8 +1,11 @@
+ Makefile | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
diff --git a/Makefile b/Makefile
-index 7892054..938a8c8 100644
+index 7892054..929564b 100644
--- a/Makefile
+++ b/Makefile
-@@ -3,7 +3,7 @@ PROG_FLGS = -D BOOLPREDEFINED
+@@ -3,27 +3,27 @@ PROG_FLGS = -D BOOLPREDEFINED
SRCS = cluster.cpp DisjointSets.cpp utility.cpp
@@ -11,16 +14,19 @@ index 7892054..938a8c8 100644
LFLAGS =
-@@ -12,7 +12,7 @@ OBJLIST = cluster.o DisjointSets.o utility.o
- CXX = g++
+ OBJLIST = cluster.o DisjointSets.o utility.o
+
+-CXX = g++
++CXX ?= g++
.cpp.o:
- $(CXX) -c $*.cpp $(CFLAGS)
+ $(CXX) $(CXXFLAGS) -c $*.cpp
- OPT = -O3
+-OPT = -O3
++OPT =
DEBUG = $(CXXDEBUGFLAGS)
-@@ -20,10 +20,10 @@ DEBUG = $(CXXDEBUGFLAGS)
+
all: cluster
cluster: $(OBJLIST)
diff --git a/sci-chemistry/cluster/metadata.xml b/sci-chemistry/cluster/metadata.xml
index 6950f7c61ee3..c411bdbae890 100644
--- a/sci-chemistry/cluster/metadata.xml
+++ b/sci-chemistry/cluster/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<longdescription>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
Cluster is a simple UNIX C++ program to build lists of collections
of interacting items from records containing interacting pairs
and larger fragments.