summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-27 14:30:48 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-27 14:30:48 +0000
commit5482b01a0c229dedfe4a853ad4a8f63ae567b243 (patch)
treee1f6f89d2f2da98e11aaff257a0bf5c77c98f3da /sci-chemistry/ball/ball-1.4.1.ebuild
parentrevbump; migrated to distutils-r1, un-needed eutils dropped, fix to building ... (diff)
downloadhistorical-5482b01a0c229dedfe4a853ad4a8f63ae567b243.tar.gz
historical-5482b01a0c229dedfe4a853ad4a8f63ae567b243.tar.bz2
historical-5482b01a0c229dedfe4a853ad4a8f63ae567b243.zip
sci-chemistry/ball: Add fix for tests, #454162; backport patches upstream included in debian package
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'sci-chemistry/ball/ball-1.4.1.ebuild')
-rw-r--r--sci-chemistry/ball/ball-1.4.1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/sci-chemistry/ball/ball-1.4.1.ebuild b/sci-chemistry/ball/ball-1.4.1.ebuild
index 44247530df62..811aa9cd3af0 100644
--- a/sci-chemistry/ball/ball-1.4.1.ebuild
+++ b/sci-chemistry/ball/ball-1.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.1.ebuild,v 1.3 2012/12/13 10:58:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ball/ball-1.4.1.ebuild,v 1.4 2013/01/27 14:30:47 jlec Exp $
EAPI=4
@@ -50,6 +50,7 @@ PATCHES=(
"${FILESDIR}"/${P}-python.patch
"${FILESDIR}"/${P}-missing-signed.patch
"${FILESDIR}"/${P}-gcc-4.7.patch
+ "${FILESDIR}"/${P}-BondOrder.xml.patch
)
pkg_setup() {
@@ -68,4 +69,14 @@ src_configure() {
$(cmake-utils_use python BALL_PYTHON_SUPPORT)
)
cmake-utils_src_configure
+ local i
+ for i in "${S}"/data/*; do
+ ln -sf "${i}" "${BUILD_DIR}"/source/TEST/ || die
+ ln -sf "${i}" "${S}"/source/TEST/ || die
+ done
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use test && cmake-utils_src_make build_tests
}