summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-12-07 15:50:08 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-12-07 15:50:08 +0000
commitc02d091bad40c48fbac16c7562c5111533e577f2 (patch)
tree4606705d544a99ab6a7d755a33463a70d54b7101 /sci-biology/tophat
parentlinux-2.6.32 support, bug #295930. (diff)
downloadhistorical-c02d091bad40c48fbac16c7562c5111533e577f2.tar.gz
historical-c02d091bad40c48fbac16c7562c5111533e577f2.tar.bz2
historical-c02d091bad40c48fbac16c7562c5111533e577f2.zip
Import from Science overlay and version bump. Thanks to Philippe Veber.
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/tophat')
-rw-r--r--sci-biology/tophat/ChangeLog10
-rw-r--r--sci-biology/tophat/Manifest4
-rw-r--r--sci-biology/tophat/metadata.xml9
-rw-r--r--sci-biology/tophat/tophat-1.0.12.ebuild32
4 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/tophat/ChangeLog b/sci-biology/tophat/ChangeLog
new file mode 100644
index 000000000000..22bb55cca671
--- /dev/null
+++ b/sci-biology/tophat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/tophat
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.1 2009/12/07 15:50:08 weaver Exp $
+
+*tophat-1.0.12 (07 Dec 2009)
+
+ 07 Dec 2009; Andrey Kislyuk <weaver@gentoo.org> +metadata.xml,
+ +tophat-1.0.12.ebuild:
+ Import from Science overlay and version bump. Thanks to Philippe Veber.
+
diff --git a/sci-biology/tophat/Manifest b/sci-biology/tophat/Manifest
new file mode 100644
index 000000000000..820c764ca16d
--- /dev/null
+++ b/sci-biology/tophat/Manifest
@@ -0,0 +1,4 @@
+DIST tophat-1.0.12.tar.gz 468781 RMD160 b705ca7bde20bd143ba1cfd084b3a3e2815a7a4d SHA1 8a39af78dc9ec797f9f30853fb24b6b0e42d0ef6 SHA256 f67b3f89aa79c7e14b40bcdba87f5aba6d322f869ca4260503e64ffcd2b621b2
+EBUILD tophat-1.0.12.ebuild 822 RMD160 5ceb851fcadba7ac329dc62893a35b93adf0ff36 SHA1 300a2e03d1bcaa44f0b118bdae0d5b911cd24d1f SHA256 38af1af5c13548f9da93bbd5f4dedfd02ea7a030e5817d09fc7cca1c9b6eb06c
+MISC ChangeLog 404 RMD160 6263aa3eb1fd473e1507ee72001da769996e0643 SHA1 783ef262c017d3557144b17264f83cf6990c4578 SHA256 20c33409393d614252db3ac11f742a6435265045db03f4ede71c18d30362bf3a
+MISC metadata.xml 259 RMD160 d9d81b67d635fabd81aef8ae0edf971211ae9072 SHA1 8e32f751c67ff891fa35405a2cf6fb33752d6eb1 SHA256 541c3fbcf299d9a8ccf4132ee61f9e53a5d737cefdaa6fdc77764d8d4c7f3110
diff --git a/sci-biology/tophat/metadata.xml b/sci-biology/tophat/metadata.xml
new file mode 100644
index 000000000000..3302123e5718
--- /dev/null
+++ b/sci-biology/tophat/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/tophat/tophat-1.0.12.ebuild b/sci-biology/tophat/tophat-1.0.12.ebuild
new file mode 100644
index 000000000000..e691698188d7
--- /dev/null
+++ b/sci-biology/tophat/tophat-1.0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.0.12.ebuild,v 1.1 2009/12/07 15:50:08 weaver Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
+HOMEPAGE="http://tophat.cbcb.umd.edu/"
+SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND="sci-biology/bowtie"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix gcc-4.4 missing include
+ sed -i '/#include <string>/ a #include <stdio.h>' "${S}/src/gff_juncs.cpp" || die
+ # fix parallel make race
+ sed -i -e 's/\$(top_builddir)\/src\///g' src/Makefile.am || die
+ eautoreconf || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS NEWS THANKS
+}