summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-25 09:09:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-25 09:09:03 +0000
commitbb84399afbdcb68681f35276edd74a83e9b01e97 (patch)
tree348418c53cc06227c5aa11d5c88c34aa77189358 /sci-biology/rebase/rebase-1006.ebuild
parentunmask gcc 4.4.3-r3 gcc-4.4.4-r1 for hardened (diff)
downloadhistorical-bb84399afbdcb68681f35276edd74a83e9b01e97.tar.gz
historical-bb84399afbdcb68681f35276edd74a83e9b01e97.tar.bz2
historical-bb84399afbdcb68681f35276edd74a83e9b01e97.zip
Version Bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/rebase/rebase-1006.ebuild')
-rw-r--r--sci-biology/rebase/rebase-1006.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-biology/rebase/rebase-1006.ebuild b/sci-biology/rebase/rebase-1006.ebuild
new file mode 100644
index 000000000000..15c172c7844b
--- /dev/null
+++ b/sci-biology/rebase/rebase-1006.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-1006.ebuild,v 1.1 2010/06/25 09:09:03 jlec Exp $
+
+EAPI="3"
+
+MY_PV=${PV#1}
+
+DESCRIPTION="A restriction enzyme database"
+LICENSE="public-domain"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+DEPEND="${RDEPEND}
+ || ( app-arch/xz-utils app-arch/lzma-utils )"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
+ -protofile proto.${MY_PV} -equivalences \
+ || die "Indexing Rebase failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${MY_PV} proto.${MY_PV} || die \
+ "Failed to install raw database."
+ fi
+ newdoc REBASE.DOC README || die "Failed to install documentation."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup} || die \
+ "Failed to install EMBOSS data files."
+ insinto /usr/share/EMBOSS/data
+ doins REBASE/embossre.equ \
+ || die "Failed to install enzyme prototypes file."
+ fi
+}