summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-19 14:13:37 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-19 14:13:37 +0000
commita37e4cbc692b87c3119edb6ed313d0e1b357f156 (patch)
tree7e189625ed0294bd80817f4327118486f8ed57aa /sci-biology/plink/plink-1.90_pre140514.ebuild
parentMajor regression fix (diff)
downloadhistorical-a37e4cbc692b87c3119edb6ed313d0e1b357f156.tar.gz
historical-a37e4cbc692b87c3119edb6ed313d0e1b357f156.tar.bz2
historical-a37e4cbc692b87c3119edb6ed313d0e1b357f156.zip
sci-biology/plink: Version BUmp, #510716
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0xB9D4F231BD1558AB!
Diffstat (limited to 'sci-biology/plink/plink-1.90_pre140514.ebuild')
-rw-r--r--sci-biology/plink/plink-1.90_pre140514.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-biology/plink/plink-1.90_pre140514.ebuild b/sci-biology/plink/plink-1.90_pre140514.ebuild
new file mode 100644
index 000000000000..8c959627996c
--- /dev/null
+++ b/sci-biology/plink/plink-1.90_pre140514.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/plink-1.90_pre140514.ebuild,v 1.1 2014/05/19 14:13:36 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Whole genome association analysis toolset"
+HOMEPAGE="http://pngu.mgh.harvard.edu/~purcell/plink/"
+SRC_URI="http://pngu.mgh.harvard.edu/~purcell/static/bin/plink140514/plink_src.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="lapack"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-arch/unzip
+ virtual/pkgconfig"
+RDEPEND="
+ sys-libs/zlib
+ lapack? ( virtual/lapack )"
+
+S="${WORKDIR}/"
+
+# Package collides with net-misc/putty. Renamed to p-link following discussion with Debian.
+# Package contains bytecode-only jar gPLINK.jar. Ignored, notified upstream.
+
+src_prepare() {
+ use lapack || sed -i '/NO_LAPACK =/s/$/1/' "${S}/Makefile" || die
+
+ sed \
+ -e 's:zlib-1.2.8/zlib.h:zlib.h:g' \
+ -i *.{c,h} || die
+
+ sed \
+ -e 's:g++:$(CXX):g' \
+ -e 's:gcc:$(CC):g' \
+ -e 's:gfortran:$(FC):g' \
+ -i Makefile || die
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ local blas
+ emake \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ ZLIB="$($(tc-getPKG_CONFIG) --libs zlib)" \
+ BLASFLAGS="$(usex lapack "" "$($(tc-getPKG_CONFIG) --libs lapack)")"
+}
+
+src_install() {
+ newbin plink p-link
+}