summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2006-06-16 08:44:04 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2006-06-16 08:44:04 +0000
commit4f2627c52563808691e2037fd1b7a4c4f29e4270 (patch)
tree8f7d033b4e8e0cc5e8fc0fba079d39c3c997b051 /sci-biology/foldingathome/foldingathome-5.0.2-r5.ebuild
parentNew version that works for glibc-2.4 users who haven't emerged glibc against ... (diff)
downloadhistorical-4f2627c52563808691e2037fd1b7a4c4f29e4270.tar.gz
historical-4f2627c52563808691e2037fd1b7a4c4f29e4270.tar.bz2
historical-4f2627c52563808691e2037fd1b7a4c4f29e4270.zip
Adding --chdir to start-stop-daemon because of bug #109707
Package-Manager: portage-2.1
Diffstat (limited to 'sci-biology/foldingathome/foldingathome-5.0.2-r5.ebuild')
-rw-r--r--sci-biology/foldingathome/foldingathome-5.0.2-r5.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/sci-biology/foldingathome/foldingathome-5.0.2-r5.ebuild b/sci-biology/foldingathome/foldingathome-5.0.2-r5.ebuild
new file mode 100644
index 000000000000..b58c10821dee
--- /dev/null
+++ b/sci-biology/foldingathome/foldingathome-5.0.2-r5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/foldingathome-5.0.2-r5.ebuild,v 1.1 2006/06/16 08:44:04 phosphan Exp $
+
+# no version number on this install dir since upgrades will be using same dir
+# (data will be stored here too)
+I="/opt/foldingathome"
+
+inherit eutils
+
+DESCRIPTION="Help simulate protein folding at home"
+HOMEPAGE="http://folding.stanford.edu/"
+SRC_URI="http://www.stanford.edu/group/pandegroup/release/FAH502-Linux.exe"
+RESTRICT="nomirror nostrip"
+
+SLOT="0"
+IUSE=""
+LICENSE="folding-at-home"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=sys-apps/baselayout-1.8.0
+ >=sys-libs/glibc-2.3.0
+ amd64? ( app-emulation/emul-linux-x86-baselibs )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" ${PN}
+}
+
+src_install() {
+ exeinto ${I}
+ newexe ${FILESDIR}/initfolding-r2 initfolding
+ newexe ${FILESDIR}/copy_client_config-${PV}-r1 copy_client_config
+
+ # Clients
+ exeinto ${I}/client1
+ doexe foldingathome
+ exeinto ${I}/client2
+ doexe foldingathome
+ exeinto ${I}/client3
+ doexe foldingathome
+ exeinto ${I}/client4
+ doexe foldingathome
+ exeinto ${I}/client5
+ doexe foldingathome
+ exeinto ${I}/client6
+ doexe foldingathome
+ exeinto ${I}/client7
+ doexe foldingathome
+ exeinto ${I}/client8
+ doexe foldingathome
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init-${PVR} foldingathome
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/folding-conf.d-r1 foldingathome
+}
+
+pkg_preinst() {
+ # the bash shell is important for "su -c" in init script
+ enewuser foldingathome -1 /bin/bash /opt/foldingathome
+}
+
+pkg_postinst() {
+ chown -R foldingathome:nogroup /opt/foldingathome
+ einfo "To run Folding@home in the background at boot:"
+ einfo " rc-update add foldingathome default"
+ einfo ""
+ einfo "Please run ${I}/initfolding to configure your client"
+ einfo "and edit /etc/conf.d/foldingathome for options"
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo "Folding@home data files were not removed."
+ einfo " Remove them manually from ${I}"
+ einfo ""
+}