summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2008-06-17 19:34:50 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2008-06-17 19:34:50 +0000
commita0ea6e7654c6a653f925180d52a6c8742a4d7da2 (patch)
tree0867b97ecb9ce2d4b001774e6d154e2cee3cd42a /sci-biology/amos/amos-2.0.7.ebuild
parentAdd alternative mirror (diff)
downloadhistorical-a0ea6e7654c6a653f925180d52a6c8742a4d7da2.tar.gz
historical-a0ea6e7654c6a653f925180d52a6c8742a4d7da2.tar.bz2
historical-a0ea6e7654c6a653f925180d52a6c8742a4d7da2.zip
Version bump and add gcc-4.3 patch, bug 227597, thanks to Marek Miller
Package-Manager: portage-2.1.5.5
Diffstat (limited to 'sci-biology/amos/amos-2.0.7.ebuild')
-rw-r--r--sci-biology/amos/amos-2.0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/amos/amos-2.0.7.ebuild b/sci-biology/amos/amos-2.0.7.ebuild
new file mode 100644
index 000000000000..ce1038f8c9a5
--- /dev/null
+++ b/sci-biology/amos/amos-2.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/amos-2.0.7.ebuild,v 1.1 2008/06/17 19:34:49 weaver Exp $
+
+EAPI="1"
+inherit qt3 eutils
+
+DESCRIPTION="A Modular, Open-Source whole genome assembler"
+HOMEPAGE="http://amos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=x11-libs/qt-3.3:3"
+RDEPEND="${DEPEND}
+ dev-perl/DBI
+ sci-biology/mummer"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ # TODO: fix parallel make. Notified upstream
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}