summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2006-02-16 03:52:17 +0000
committerDaniel Goller <morfic@gentoo.org>2006-02-16 03:52:17 +0000
commitfdf8b88056cbb7c3fc7ca3878bfb68365e000bb3 (patch)
tree8966d4a71095651269ed49daf40bca9c7f5757be /sci-astronomy
parentStable on SPARC wrt bug #122721. (diff)
downloadhistorical-fdf8b88056cbb7c3fc7ca3878bfb68365e000bb3.tar.gz
historical-fdf8b88056cbb7c3fc7ca3878bfb68365e000bb3.tar.bz2
historical-fdf8b88056cbb7c3fc7ca3878bfb68365e000bb3.zip
Change logic for Makefile fix closing bug #122919
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog5
-rw-r--r--sci-astronomy/celestia/Manifest12
-rw-r--r--sci-astronomy/celestia/celestia-1.4.0.ebuild8
3 files changed, 14 insertions, 11 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index c0b345442fc3..bfb575b97aad 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.10 2006/02/01 17:20:48 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.11 2006/02/16 03:52:17 morfic Exp $
+
+ 16 Feb 2006; Daniel Goller <morfic@gentoo.org> celestia-1.4.0.ebuild:
+ Change logic for Makefile fix closing bug #122919
01 Feb 2006; Gustavo Zacarias <gustavoz@gentoo.org> celestia-1.4.0.ebuild:
Keyworded ~sparc
diff --git a/sci-astronomy/celestia/Manifest b/sci-astronomy/celestia/Manifest
index 6e0d96a59d23..fb79db7722e2 100644
--- a/sci-astronomy/celestia/Manifest
+++ b/sci-astronomy/celestia/Manifest
@@ -1,18 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 9886826072761ddbf73c17d4a2783c83 ChangeLog 6829
+MD5 39e8bab62af36e8581df47631e20de33 ChangeLog 6952
MD5 6be90f964bc6ca0195b0623338dfd1f0 celestia-1.3.2.ebuild 3063
-MD5 96c28260f9cd07ee56b3675e8dd88865 celestia-1.4.0.ebuild 2929
+MD5 511913cb6dac5097274e61a8257fa1a5 celestia-1.4.0.ebuild 2943
MD5 f659f2616eeaaa4d3b6422e586d2bfa2 files/celestia-1.3.2-noarts.patch 3566
MD5 d4ff8e51fb3a546279e7442cf24e07d7 files/digest-celestia-1.3.2 68
MD5 8e1dfea9c274b2242b921a467ec1d54b files/digest-celestia-1.4.0 68
MD5 f96a6eb019a59bf1a643b96c43657af8 files/resmanager.h.patch 893
MD5 1b55bd73a1313e288a88762af6cd0fb7 metadata.xml 330
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2-ecc0.1.6 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFD4O4AKRy60XGEcJIRAq5zAJ4g+hnWwgJbkyO6csBAW4OWP8AuQgCeITVc
-qIBvtu/SXdfPmO1fq1pq6SU=
-=nZUY
+iD8DBQFD9ABg/aM9DdBw91cRAlVIAKDM+QCWdpITHDLLeWonbXd6u95MOgCghDzS
+x51HRR0YAjF73fOrj7pOyxw=
+=S8sw
-----END PGP SIGNATURE-----
diff --git a/sci-astronomy/celestia/celestia-1.4.0.ebuild b/sci-astronomy/celestia/celestia-1.4.0.ebuild
index 1b154d6b1d76..bfcb40623067 100644
--- a/sci-astronomy/celestia/celestia-1.4.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.6 2006/02/01 17:20:48 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.7 2006/02/16 03:52:17 morfic Exp $
inherit eutils flag-o-matic gnome2 kde-functions
@@ -66,7 +66,7 @@ src_compile() {
# replaced with dohtml in src_install
sed -i -e "s:manual::g" Makefile.in
- if [ "${mygui}" = "kde" ]; then
+ if [ "${mygui}" == "kde" ]; then
set-kdedir 3
set-qtdir 3
export kde_widgetdir="$KDEDIR/lib/kde3/plugins/designer"
@@ -82,7 +82,7 @@ src_compile() {
|| die "econf failed"
#fix Makefiles to avoid Access Violations while fixing bug #119339
- if ! use gnome ; then
+ if [ "${mygui}" != "gnome" ] ; then
for d in . src data extras textures textures/lores textures/medres textures/hires models shaders fonts po ; do
sed -i -e "s#pkgdatadir = /usr/share/celestia#pkgdatadir = ${D}/usr/share/celestia#" $d/Makefile; done
fi
@@ -91,7 +91,7 @@ src_compile() {
}
src_install() {
- if [ "${mygui}" = "gnome" ]; then
+ if [ "${mygui}" == "gnome" ]; then
gnome2_src_install
else
einstall || die "einstall failed"