summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-07-16 18:52:34 +0000
committerDon Seiler <rizzo@gentoo.org>2003-07-16 18:52:34 +0000
commit8ab1c1a0972e2381a10ca0bedacfbed0308f791f (patch)
treeefc1d06062dcb89f41831b22ca92010aeb0fe54b /net-www
parentcleanup (diff)
downloadhistorical-8ab1c1a0972e2381a10ca0bedacfbed0308f791f.tar.gz
historical-8ab1c1a0972e2381a10ca0bedacfbed0308f791f.tar.bz2
historical-8ab1c1a0972e2381a10ca0bedacfbed0308f791f.zip
Initial Commit
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phpwebsite/ChangeLog8
-rw-r--r--net-www/phpwebsite/Manifest2
-rw-r--r--net-www/phpwebsite/phpwebsite-0.9.2_p1.ebuild52
3 files changed, 62 insertions, 0 deletions
diff --git a/net-www/phpwebsite/ChangeLog b/net-www/phpwebsite/ChangeLog
new file mode 100644
index 000000000000..9a50fdd93af7
--- /dev/null
+++ b/net-www/phpwebsite/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/phpwebsite
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpwebsite/ChangeLog,v 1.1 2003/07/16 18:52:27 rizzo Exp $
+
+*phpwebsite-0.9.2_p1 (16 Jul 2003)
+
+ 16 Jul 2003; Don Seiler <rizzo@gentoo.org>:
+ Initial import. Ebuild submitted by me.
diff --git a/net-www/phpwebsite/Manifest b/net-www/phpwebsite/Manifest
new file mode 100644
index 000000000000..e2354f673fa5
--- /dev/null
+++ b/net-www/phpwebsite/Manifest
@@ -0,0 +1,2 @@
+MD5 ed106055f87ad7eed82bb0bbbea8617d ChangeLog 340
+MD5 d6224574a4b4b23d9b826bc54ca43050 phpwebsite-0.9.2_p1.ebuild 1587
diff --git a/net-www/phpwebsite/phpwebsite-0.9.2_p1.ebuild b/net-www/phpwebsite/phpwebsite-0.9.2_p1.ebuild
new file mode 100644
index 000000000000..fc1a6896e32f
--- /dev/null
+++ b/net-www/phpwebsite/phpwebsite-0.9.2_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Don Seiler <rizzo@gentoo.org>
+# $Header $
+
+
+HOSTNAME=`hostname`
+DESCRIPTION="phpWebSite provides a complete web site content management system. Web-based administration allows for easy maintenance of interactive, community-driven web sites."
+HOMEPAGE="http://phpwebsite.appstate.edu"
+MY_PV="${PV/_p/-}"
+S="${WORKDIR}/${PN}-${MY_PV}-full"
+SRC_URI="mirror://sourceforge/phpwebsite/${PN}-${MY_PV}-full.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/php"
+
+HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache2/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install() {
+ cd ${S}
+ dodir ${HTTPD_ROOT}/phpwebsite
+ cp -r * ${D}/${HTTPD_ROOT}/phpwebsite
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You will need to create a database for phpWebSite"
+ einfo "on your own before starting setup. You will also need"
+ einfo "to run:"
+ einfo
+ einfo "${HTTPD_ROOT}/phpwebsite/setup/secure_setup.sh setup"
+ einfo
+ einfo "Once you have a database ready proceed to"
+ einfo "http://$HOSTNAME/phpwebsite to continue installation."
+ einfo
+ einfo "Once you are done with installation you need to run"
+ einfo
+ einfo "${HTTPD_ROOT}/phpwebsite/setup/secure_phpws.sh run apache users"
+ einfo
+}