summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Glover <jmglov@gentoo.org>2004-06-17 12:32:11 +0000
committerJosh Glover <jmglov@gentoo.org>2004-06-17 12:32:11 +0000
commit82837e92923c8e7275561668d8dba2e88509268a (patch)
tree0f4f5d1bbbfe4ca5946910327a7242c49a2e2fd8 /net-www
parentnew version (diff)
downloadhistorical-82837e92923c8e7275561668d8dba2e88509268a.tar.gz
historical-82837e92923c8e7275561668d8dba2e88509268a.tar.bz2
historical-82837e92923c8e7275561668d8dba2e88509268a.zip
This package was submitted by Josh Glover in bug #54196
Diffstat (limited to 'net-www')
-rw-r--r--net-www/online-bookmarks/ChangeLog10
-rw-r--r--net-www/online-bookmarks/Manifest4
-rw-r--r--net-www/online-bookmarks/files/digest-online-bookmarks-0.2.61
-rw-r--r--net-www/online-bookmarks/metadata.xml9
-rw-r--r--net-www/online-bookmarks/online-bookmarks-0.2.6.ebuild47
5 files changed, 71 insertions, 0 deletions
diff --git a/net-www/online-bookmarks/ChangeLog b/net-www/online-bookmarks/ChangeLog
new file mode 100644
index 000000000000..13d67950dab2
--- /dev/null
+++ b/net-www/online-bookmarks/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/online-bookmarks
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/online-bookmarks/ChangeLog,v 1.1 2004/06/17 12:32:11 jmglov Exp $
+
+*online-bookmarks-0.2.6 (17 Jun 2004)
+
+ 17 Jun 2004; Josh Glover <jmglov@gentoo.org> metadata.xml,
+ online-bookmarks-0.2.6.ebuild:
+ This package was submitted by Josh Glover in bug #54196
+
diff --git a/net-www/online-bookmarks/Manifest b/net-www/online-bookmarks/Manifest
new file mode 100644
index 000000000000..13dfe1d86b69
--- /dev/null
+++ b/net-www/online-bookmarks/Manifest
@@ -0,0 +1,4 @@
+MD5 f417d102f1885f8847e2cfa3b79d05b9 online-bookmarks-0.2.6.ebuild 1464
+MD5 8cbe13cf7fd412cfdf3609b3bf67eebe metadata.xml 504
+MD5 7a9f9265ee64c22cfc584206a7acc6a8 ChangeLog 421
+MD5 17d5aedf274dc89da9c51a078276b928 files/digest-online-bookmarks-0.2.6 73
diff --git a/net-www/online-bookmarks/files/digest-online-bookmarks-0.2.6 b/net-www/online-bookmarks/files/digest-online-bookmarks-0.2.6
new file mode 100644
index 000000000000..b20af2e187ad
--- /dev/null
+++ b/net-www/online-bookmarks/files/digest-online-bookmarks-0.2.6
@@ -0,0 +1 @@
+MD5 507fca2a9c769024377fe90180b534a2 online-bookmarks-0.2.6.tar.gz 34818
diff --git a/net-www/online-bookmarks/metadata.xml b/net-www/online-bookmarks/metadata.xml
new file mode 100644
index 000000000000..6f9c59dc30c7
--- /dev/null
+++ b/net-www/online-bookmarks/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jmglov@gentoo.org</email>
+ <name>Josh Glover</name>
+ </maintainer>
+ <longdescription>online-bookmarks is a Bookmark management system to store your Bookmarks, Favorites and Links right in the WWW where they actually belong to. It is meant for people who work often with different computers and browsers.</longdescription>
+</pkgmetadata>
diff --git a/net-www/online-bookmarks/online-bookmarks-0.2.6.ebuild b/net-www/online-bookmarks/online-bookmarks-0.2.6.ebuild
new file mode 100644
index 000000000000..d1410edd5dae
--- /dev/null
+++ b/net-www/online-bookmarks/online-bookmarks-0.2.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/online-bookmarks/online-bookmarks-0.2.6.ebuild,v 1.1 2004/06/17 12:32:11 jmglov Exp $
+
+inherit webapp
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="a Bookmark management system to store your Bookmarks, Favorites and Links right in the WWW where they actually belong"
+HOMEPAGE="http://www.frech.ch/online-bookmarks/index.php"
+SRC_URI="http://www.frech.ch/online-bookmarks/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE=""
+
+# Glimpse is actually optional, but since there is no USE flag, require it
+RDEPEND="virtual/php"
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ # prepare ${D} for our arrival
+ webapp_src_preinst
+
+ # Install documentation and then get rid of it so it does not clog up
+ # webapp-config instances (except INSTALL, which will be our postinstall
+ # documentation)
+ dodoc CHANGES CREDITS GPL.txt INSTALL LICENSE README UPGRADE VERSION
+ rm CHANGES CREDITS GPL.txt LICENSE README UPGRADE VERSION
+
+ # Install to webapp-config master directory
+ cp -a * "${D}/${MY_HTDOCSDIR}"
+
+ # Identify the configuration files that this app uses
+ webapp_configfile "${MY_HTDOCSDIR}/config/config.php"
+ webapp_configfile "${MY_HTDOCSDIR}/config/connect.php"
+
+ # Add the post-installation instructions
+ webapp_postinst_txt en INSTALL
+
+ # Let webapp.eclass do the rest
+ webapp_src_install
+}