summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-09-08 13:21:10 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-09-08 13:21:10 +0000
commit5b283ba52bb427ae751cb77a89bb3abda7ff20cc (patch)
tree16b562c04c36d772d35ea94a95ddfe2561216e40 /net-www
parentAdded patch to compile using gcc3 (diff)
downloadhistorical-5b283ba52bb427ae751cb77a89bb3abda7ff20cc.tar.gz
historical-5b283ba52bb427ae751cb77a89bb3abda7ff20cc.tar.bz2
historical-5b283ba52bb427ae751cb77a89bb3abda7ff20cc.zip
happy happy joy joy. new galeon2 cvs snapshot ebuilds
Diffstat (limited to 'net-www')
-rw-r--r--net-www/galeon-cvs/ChangeLog9
-rw-r--r--net-www/galeon-cvs/files/digest-galeon-cvs-200209080
-rw-r--r--net-www/galeon-cvs/galeon-cvs-20020908.ebuild54
3 files changed, 63 insertions, 0 deletions
diff --git a/net-www/galeon-cvs/ChangeLog b/net-www/galeon-cvs/ChangeLog
new file mode 100644
index 000000000000..7ffc0292b355
--- /dev/null
+++ b/net-www/galeon-cvs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-www/galeon-cvs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon-cvs/ChangeLog,v 1.1 2002/09/08 13:21:10 spider Exp $
+
+*galeon-20020908 (08 September 2002)
+
+ 08 Sep 2002; Spider <spider@gentoo.org> Changelog galeon-cvs-20020908.ebuild :
+ new package. cvs package based on winex-cvs
+
diff --git a/net-www/galeon-cvs/files/digest-galeon-cvs-20020908 b/net-www/galeon-cvs/files/digest-galeon-cvs-20020908
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-www/galeon-cvs/files/digest-galeon-cvs-20020908
diff --git a/net-www/galeon-cvs/galeon-cvs-20020908.ebuild b/net-www/galeon-cvs/galeon-cvs-20020908.ebuild
new file mode 100644
index 000000000000..8c1512d4c7ca
--- /dev/null
+++ b/net-www/galeon-cvs/galeon-cvs-20020908.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon-cvs/galeon-cvs-20020908.ebuild,v 1.1 2002/09/08 13:21:10 spider Exp $
+
+
+ECVS_TOP_DIR="${PORTAGE_TMPDIR}"
+ECVS_SERVER="anoncvs.gnome.org:/cvs/gnome"
+ECVS_MODULE="galeon"
+ECVS_CVS_OPTIONS="-dP"
+
+inherit cvs
+inherit gnome2
+
+S=${WORKDIR}/${ECVS_MODULE}
+DESCRIPTION="Galeon is a Web Browser for the Gnome Desktop. The web, only the web."
+HOMEPAGE="http://www.galeon.org/"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+DEPEND="virtual/x11
+ >=net-www/mozilla-1.1-r1
+ >=gnome-base/gnome-2.0.0"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd ${S}
+ local myconf=" --with-mozilla-snapshot --disable-werror"
+ local baseopts="--prefix=/usr\
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib"
+
+ if [ ! -f ./configure ]; then
+ ./autogen.sh ${baseopts} ${myconf} || die "autogen failed"
+ else
+ ./configure ${baseopts} ${myconf} || die "configure failed"
+ fi
+ emake || die "compile failed"
+}
+
+src_install () {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ einstall scrollkeeper_localstate_dir=${D}/var/lib/scrollkeeper/ || die "make install failed"
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+
+ dodoc AUTHORS COPYING COPYING.README ChangeLog ChangeLog-1.0 FAQ INSTALL README README.ExtraPrefs THANKS TODO NEWS
+}
+