summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-02-03 22:23:40 +0000
committerDean Bailey <alron@gentoo.org>2003-02-03 22:23:40 +0000
commit63d82df66774c03c2669dd4a026dc1d7b431cb79 (patch)
treeba9452f474b97c361dbd6538cf3175079aa850c4 /net-www/horde
parentMasked package as it causes xmms to crash. (diff)
downloadhistorical-63d82df66774c03c2669dd4a026dc1d7b431cb79.tar.gz
historical-63d82df66774c03c2669dd4a026dc1d7b431cb79.tar.bz2
historical-63d82df66774c03c2669dd4a026dc1d7b431cb79.zip
updated horde to version 2.2
Diffstat (limited to 'net-www/horde')
-rw-r--r--net-www/horde/ChangeLog6
-rw-r--r--net-www/horde/files/digest-horde-2.21
-rw-r--r--net-www/horde/horde-2.2.ebuild70
3 files changed, 76 insertions, 1 deletions
diff --git a/net-www/horde/ChangeLog b/net-www/horde/ChangeLog
index a97335269ea2..f48f2d84c755 100644
--- a/net-www/horde/ChangeLog
+++ b/net-www/horde/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-www/horde
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde/ChangeLog,v 1.3 2002/12/13 11:00:27 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/ChangeLog,v 1.4 2003/02/03 22:23:40 alron Exp $
+*horde-2.2 (03 Feb 2003)
+ 03 Feb 2003; Dean Bailey <alron@gentoo.org> horde-2.2 :
+ Updated to version 2.2 of the Horde Framework.
+
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*horde-2.1 (21 Oct 2002)
diff --git a/net-www/horde/files/digest-horde-2.2 b/net-www/horde/files/digest-horde-2.2
new file mode 100644
index 000000000000..e1cc8780f885
--- /dev/null
+++ b/net-www/horde/files/digest-horde-2.2
@@ -0,0 +1 @@
+MD5 3074fe5e4a284e74af37e608f9981401 horde-2.2.tar.gz 526643
diff --git a/net-www/horde/horde-2.2.ebuild b/net-www/horde/horde-2.2.ebuild
new file mode 100644
index 000000000000..aac659054e56
--- /dev/null
+++ b/net-www/horde/horde-2.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde/horde-2.2.ebuild,v 1.1 2003/02/03 22:23:40 alron Exp $
+
+DESCRIPTION="Horde Application Framework ${PV}"
+HOMEPAGE="http://www.horde.org"
+SRC_URI="ftp://ftp.horde.org/pub/horde/tarballs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc "
+DEPEND=""
+RDEPEND=">=dev-php/mod_php-4.1.0
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21-r1
+ >=dev-php/PEAR-Log-1.1"
+IUSE=""
+
+# We will use these to set the permissions properly
+HTTPD_USER="apache"
+HTTPD_GROUP=`grep $HTTPD_USER /etc/passwd |cut -d: -f4`
+
+# Allow users to move the default data directory by setting the
+# home directory of the 'apache' user elsewhere.
+HTTPD_ROOT=`grep $HTTPD_USER /etc/passwd | cut -d: -f6`/htdocs
+
+
+
+pkg_setup() {
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eewarn "HTTPD_ROOT is null!"
+ eewarn "You probably want to check /etc/passwd"
+ die "Need to have a place to put horde in"
+ fi
+ if [ -L ${HTTPD_ROOT}/horde ] ; then
+ ewarn "You need to unmerge your old Horde version first."
+ ewarn "Horde will be installed into ${HTTPD_ROOT}/horde"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ dodir ${HTTPD_ROOT}/horde
+ cp -r . ${D}/${HTTPD_ROOT}/horde
+
+ # protecting files
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${D}/${HTTPD_ROOT}/horde
+ find ${D}/${HTTPD_ROOT}/horde/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/ -type d -exec chmod 0750 {} \;
+ chmod 0000 ${D}/${HTTPD_ROOT}/horde/test.php
+}
+
+pkg_postinst() {
+ einfo "Horde requires PHP to have :"
+ einfo " ==> 'short_open_tag enabled = On'"
+ einfo " ==> 'magic_quotes_runtime set = Off'"
+ einfo " ==> 'file_uploads enabled = On'"
+ einfo "Please edit /etc/php4/php.ini."
+ einfo ""
+ einfo "Please read ${HTTPD_ROOT}/horde/docs/INSTALL !"
+}
+
+